summaryrefslogtreecommitdiff
path: root/net-misc/csync
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /net-misc/csync
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'net-misc/csync')
-rw-r--r--net-misc/csync/Manifest2
-rw-r--r--net-misc/csync/csync-0.50.0-r1.ebuild47
-rw-r--r--net-misc/csync/files/csync-0.50.0-gcc_5_and_8.patch36
3 files changed, 85 insertions, 0 deletions
diff --git a/net-misc/csync/Manifest b/net-misc/csync/Manifest
index dd7c6f1660fd..0dfd56f8765d 100644
--- a/net-misc/csync/Manifest
+++ b/net-misc/csync/Manifest
@@ -1,3 +1,5 @@
+AUX csync-0.50.0-gcc_5_and_8.patch 1346 BLAKE2B 55c78622122e429b5a72790c5db3b0e2e063f419ab85dac460541aac121bf8d957a2be443837023e745c71debfe908a8fd5f75d041b16f7c22610da9e049532b SHA512 fb739031b2eca4f69f1384262214b13d5ccfd0abc64d889bb1b69f3a04473a43129ed26990aebcfd51e5b98b70649d9fac36a7eb116d162631f074d60ea82a41
DIST csync-0.50.0.tar.xz 2705992 BLAKE2B b59ee573eea9bd7c46302d3db782b46f978d62219e3a3e70e97a012d1ea32681a1aa3133505c3833c5d1e6d0fcb90cc985d21553086ed8de28c7ca9fc8aa0099 SHA512 babe44af3a4f0bf58e011f1c33c7a6df9bc7751e03714dd64d8269c7c51bcc7f2ab32c4d286e5a11465c9498c988d1812c426a4f415f1138a4fb9fa341e1e29a
+EBUILD csync-0.50.0-r1.ebuild 1130 BLAKE2B a9e58b3350b243415498d64c5c050f25f859e9fe1f95c81ed5e1f2b49e5016a93fc216c30800c55b6da37614f2de3614910f328c57a4daf750e1bd51b7f60bff SHA512 f563547196e0f0587827a83c6dd939510f3635f8c2ba5b60e7e8b059f360328324e1269a2f971c34632e623f120b4cbc2bec903505427eeb8db68670916170c5
EBUILD csync-0.50.0.ebuild 1202 BLAKE2B 1332fa048c525811d42889ae8a36e7a3b02faf815455b0e9d274d705c13d29ee47818fde2b529e5fe75a8935528124272dcc0bfce4eb7c8290a66da0444f6b96 SHA512 ac9d02accd433cc1b07675503c3104416a6e948c0e5be52ebf0ca794749db68d5253b3ddf51b1bfa75f6cece33e5e7d48cde4c828812db39a2956926a369b36f
MISC metadata.xml 354 BLAKE2B 5a0ff4b19f98eefe67e4b6dc04ea59cdb76abfb4f8799163cf2c87a565660e84182ca565eb641b43b66083d9d9dde12cb156edc84b06e889edf0cc9a60e07d68 SHA512 513b19184444fb46882523fc160043d7d530d202aa253f44ace9fc97fad8dda7748083bd992921d93ebd62a12397e69a086932818e317f75fb7dfa478ab3f1ba
diff --git a/net-misc/csync/csync-0.50.0-r1.ebuild b/net-misc/csync/csync-0.50.0-r1.ebuild
new file mode 100644
index 000000000000..5374066247df
--- /dev/null
+++ b/net-misc/csync/csync-0.50.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="lightweight file synchronizer utility"
+HOMEPAGE="https://www.csync.org/"
+SRC_URI="https://open.cryptomilk.org/attachments/download/27/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc iconv samba +sftp test"
+
+RDEPEND=">=dev-db/sqlite-3.4:3
+ net-libs/neon[ssl]
+ iconv? ( virtual/libiconv )
+ samba? ( >=net-fs/samba-3.5 )
+ sftp? ( >=net-libs/libssh-0.5 )
+ !net-misc/ocsync"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cmocka )"
+
+PATCHES=( "${FILESDIR}"/${P}-gcc_5_and_8.patch )
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # proper docdir
+ sed -e "s:/doc/${PN}:/doc/${PF}:" \
+ -i doc/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
+ -DWITH_ICONV="$(usex iconv)"
+ -DUNIT_TESTING="$(usex test)"
+ $(cmake-utils_use_find_package doc Doxygen)
+ $(cmake-utils_use_find_package samba SMBClient)
+ $(cmake-utils_use_find_package sftp LibSSH)
+ )
+ cmake-utils_src_configure
+}
diff --git a/net-misc/csync/files/csync-0.50.0-gcc_5_and_8.patch b/net-misc/csync/files/csync-0.50.0-gcc_5_and_8.patch
new file mode 100644
index 000000000000..44bcc3ed6819
--- /dev/null
+++ b/net-misc/csync/files/csync-0.50.0-gcc_5_and_8.patch
@@ -0,0 +1,36 @@
+diff -Naur csync-0.50.0.orig/modules/csync_smb.c csync-0.50.0/modules/csync_smb.c
+--- csync-0.50.0.orig/modules/csync_smb.c 2013-07-29 14:04:37.000000000 +0200
++++ csync-0.50.0/modules/csync_smb.c 2018-12-06 23:08:05.320992985 +0100
+@@ -49,7 +49,7 @@
+ char *pw, int pwlen)
+ {
+ static int try_krb5 = 1;
+- char *h;
++ const char *h;
+
+ (void) smb_ctx;
+ (void) shr;
+diff -Naur csync-0.50.0.orig/src/csync_log.h csync-0.50.0/src/csync_log.h
+--- csync-0.50.0.orig/src/csync_log.h 2013-07-29 14:04:37.000000000 +0200
++++ csync-0.50.0/src/csync_log.h 2018-12-06 23:11:34.280239832 +0100
+@@ -55,7 +55,7 @@
+ };
+
+ #define CSYNC_LOG(priority, ...) \
+- csync_log(priority, __FUNCTION__, __VA_ARGS__)
++ csync_log(priority, __func__, __VA_ARGS__)
+
+ void csync_log(int verbosity,
+ const char *function,
+diff -Naur csync-0.50.0.orig/tests/csync_tests/check_csync_log.c csync-0.50.0/tests/csync_tests/check_csync_log.c
+--- csync-0.50.0.orig/tests/csync_tests/check_csync_log.c 2013-04-22 13:00:35.000000000 +0200
++++ csync-0.50.0/tests/csync_tests/check_csync_log.c 2018-12-06 23:11:34.280239832 +0100
+@@ -115,7 +115,7 @@
+ rc = csync_set_log_callback(check_log_callback);
+ assert_int_equal(rc, 0);
+
+- csync_log(1, __FUNCTION__, "rc = %d", rc);
++ csync_log(1, __func__, "rc = %d", rc);
+
+ rc = _tstat(path, &sb);
+