summaryrefslogtreecommitdiff
path: root/net-misc/croc/croc-9.6.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-01 11:48:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-01 11:48:39 +0000
commit1e39e6a8c127767a57f0465ed9ece4fefb44b4ae (patch)
tree3559e11cac3d1d8c48d4a253876d1927017c508f /net-misc/croc/croc-9.6.4.ebuild
parentd13aef5a4ce5eb3b31565d0d9e67e903e5e932df (diff)
gentoo auto-resync : 01:02:2024 - 11:48:38
Diffstat (limited to 'net-misc/croc/croc-9.6.4.ebuild')
-rw-r--r--net-misc/croc/croc-9.6.4.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/net-misc/croc/croc-9.6.4.ebuild b/net-misc/croc/croc-9.6.4.ebuild
deleted file mode 100644
index a3b14bea8b93..000000000000
--- a/net-misc/croc/croc-9.6.4.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 go-module systemd
-
-DESCRIPTION="Easily and securely send things from one computer to another"
-HOMEPAGE="https://github.com/schollz/croc"
-SRC_URI="https://github.com/schollz/croc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~sultan/distfiles/net-misc/croc/${P}-deps.tar.xz"
-
-LICENSE="Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
-
-RDEPEND="
- acct-group/croc
- acct-user/croc
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-disable-network-tests-r1.patch"
-)
-
-DOCS=( README.md )
-
-src_prepare() {
- default
- # Replace User=nobody with User=croc
- sed -i -e "s|\(^User=\).*|\1croc|g" croc.service || die
- # Rename bash completion function
- sed -i -e "s|_cli_bash_autocomplete|_croc|g" \
- src/install/bash_autocomplete || die
-}
-
-src_compile() {
- ego build
-}
-
-src_install() {
- dobin croc
- systemd_dounit croc.service
- newbashcomp src/install/bash_autocomplete croc
- einstalldocs
-}
-
-src_test() {
- ego test -work ./...
-}