summaryrefslogtreecommitdiff
path: root/net-misc/croc/croc-9.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-20 14:38:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-20 14:38:48 +0100
commitdd45cee79a4c905271356e96af531293b62c429b (patch)
treebadf99f89a2e65ae16720e8c67fad03183873dd0 /net-misc/croc/croc-9.6.0.ebuild
parent32fc5f4a2c2017f1f9c628fab9dcb5a54c3e6f03 (diff)
gentoo auto-resync : 20:08:2022 - 14:38:48
Diffstat (limited to 'net-misc/croc/croc-9.6.0.ebuild')
-rw-r--r--net-misc/croc/croc-9.6.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-misc/croc/croc-9.6.0.ebuild b/net-misc/croc/croc-9.6.0.ebuild
new file mode 100644
index 000000000000..03dce788293d
--- /dev/null
+++ b/net-misc/croc/croc-9.6.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 go-module systemd
+
+DESCRIPTION="Easily and securely send things from one computer to another"
+HOMEPAGE="https://github.com/schollz/croc"
+
+SRC_URI="https://github.com/schollz/croc/releases/download/v${PV}/${PN}_${PV}_src.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ acct-group/croc
+ acct-user/croc
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-disable-network-tests-r1.patch"
+)
+
+DOCS=( README.md )
+
+src_prepare() {
+ default
+ # Replace User=nobody with User=croc
+ sed -i -e "s|\(^User=\).*|\1croc|g" croc.service || die
+ # Rename bash completion function
+ sed -i -e "s|_cli_bash_autocomplete|_croc|g" \
+ src/install/bash_autocomplete || die
+}
+
+src_compile() {
+ ego build
+}
+
+src_install() {
+ dobin croc
+ systemd_dounit croc.service
+ newbashcomp src/install/bash_autocomplete croc
+ einstalldocs
+}
+
+src_test() {
+ ego test -work ./...
+}