summaryrefslogtreecommitdiff
path: root/net-misc/connman-ui/connman-ui-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/connman-ui/connman-ui-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/connman-ui/connman-ui-9999.ebuild')
-rw-r--r--net-misc/connman-ui/connman-ui-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/connman-ui/connman-ui-9999.ebuild b/net-misc/connman-ui/connman-ui-9999.ebuild
new file mode 100644
index 000000000000..67ca7343806a
--- /dev/null
+++ b/net-misc/connman-ui/connman-ui-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools git-r3
+
+DESCRIPTION="A full-featured GTK based trayicon UI for ConnMan"
+HOMEPAGE="https://github.com/tbursztyka/connman-ui"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/tbursztyka/connman-ui.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+CDEPEND="
+ dev-libs/glib:2
+ sys-apps/dbus
+ x11-libs/gtk+:3
+"
+RDEPEND="${CDEPEND}
+ net-misc/connman
+"
+DEPEND="${CDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}