summaryrefslogtreecommitdiff
path: root/net-misc/chrony
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-18 23:57:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-18 23:57:59 +0000
commitd39fec05a2fac9978cd77634744637509744b561 (patch)
treed6c800b18c7b6a3c88e80b284f5c91a060e1ecc7 /net-misc/chrony
parent220240f060e150ba4c4bb2d0f2a07f7c8f9de480 (diff)
gentoo auto-resync : 18:01:2023 - 23:57:58
Diffstat (limited to 'net-misc/chrony')
-rw-r--r--net-misc/chrony/Manifest3
-rw-r--r--net-misc/chrony/chrony-4.3-r4.ebuild263
-rw-r--r--net-misc/chrony/chrony-9999.ebuild9
3 files changed, 271 insertions, 4 deletions
diff --git a/net-misc/chrony/Manifest b/net-misc/chrony/Manifest
index 2892db6ecb8a..133ab09478bb 100644
--- a/net-misc/chrony/Manifest
+++ b/net-misc/chrony/Manifest
@@ -7,5 +7,6 @@ AUX chronyd.init-r2 1694 BLAKE2B 5ee55954c8afc2df09291dd7df4c3f1b3a01f97079ae197
DIST chrony-4.3.tar.gz 593560 BLAKE2B 51ba6d19312fd52cd6d6d8ab9437c886a3779877170674db6dc37d657e849101e2669fd6c8723d24e43c895cd1924c3d8d2ff442baeef9abe8a6c313929edf5f SHA512 1394bac3ed684352fe89b7fef7da50e61f9f522abee807627ae1fc4c2dde891017bc8e5b13759fced028f3a1e875d5e4e5a4f85de65c63b5f83d0ca03bb4c5df
DIST chrony-4.3.tar.gz.asc 833 BLAKE2B 12399205da4ee5c442207bfdf936ac88552a49b21b0db8c15b09118b579e2076f7cfec6ad916b08b41edc4f9f8e03b13d7758ed08e116bee54d0f0f9cd68a505 SHA512 300b06f253ac3727edb86a1b7c337f9529ee752bbb471b266217b6a8ac5183e827264177a3210d436425d746673bf11fbdc41da145673213e28165197c6c76b7
EBUILD chrony-4.3-r2.ebuild 6863 BLAKE2B e178e5adb7433480d05f1ce9446cd27c2f93ed6c822a16ce0814ee2d0fee97e31e49eb29d052747fc88be31f09067f70c9ce7e20f35756f3efc304960eb2dc81 SHA512 d78c1c509404ecd9deb35e6912db2daa272e35b67b46dfd231fdd288ab9432daaa6a17485fb1d3eca6ec9cfd652fecb25189527cca8a7ff9d632395c23d1b128
-EBUILD chrony-9999.ebuild 6733 BLAKE2B cb8d7772b290da4aa82645073b2337a4f0684834e93d258ea5189708ad76d123d9401b6e0dd02a52277854e2a8bb3e26f3a323adb7359b0c2bc7d71c78934ca5 SHA512 8cbfeefb39b8cee35d02192aa09258c30a2204eba9ada5eb7b7e7c9707885bdb49ae550065ab8283a0482626f0826b625363793bf0f758c751cac06fb4f9a738
+EBUILD chrony-4.3-r4.ebuild 6973 BLAKE2B 8ebbf2d39ecbd64bba784da2da5cf7b4546d750e6bb35a11092988e6cf5e9b360b13fa24b8f4352b0256aa6bd9856da81e1f044744800d15930ecff10c8cec54 SHA512 ba5406ef1235153434a362e42e46899898ece011c75c41da9c5a6990a7b43b157d384c99b1f600fba94cc306d2c6ede1f14284d8623d0d81baeef28ff5145125
+EBUILD chrony-9999.ebuild 6887 BLAKE2B e1f47d9a864876429592bbdfbf3702a1c29536ef41ecbb71b856df04197da88d93d5cc9b884b565f5931ab5bca4afde6f00335849124a7001c0a4da06a8aa9ff SHA512 02a08bf264a0f198b5d495dbaabbc55693f7178ae6e6d78e5f35acab3b6982269f4eeeb532379bb24f2984f984d77970d7519fed14d2633c4a0b1b311c1e327a
MISC metadata.xml 2300 BLAKE2B 8d0e8822361fef70945eab4eb365fee2f0c278fb36ad0641520310bf895d04202fce88d485149d021ebf577ee848b408cf46f4141f8606ff020d2483370c3b16 SHA512 57c813c655fa7a5083f26f908d7476dd165284feef014c750e845c60830af7baffe91e9444915d3994b053498714b4e717bfe7a2af34e90de50d823542c913d0
diff --git a/net-misc/chrony/chrony-4.3-r4.ebuild b/net-misc/chrony/chrony-4.3-r4.ebuild
new file mode 100644
index 000000000000..0bc60877386d
--- /dev/null
+++ b/net-misc/chrony/chrony-4.3-r4.ebuild
@@ -0,0 +1,263 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="NTP client and server programs"
+HOMEPAGE="https://chrony.tuxfamily.org/ https://git.tuxfamily.org/chrony/chrony.git"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.tuxfamily.org/chrony/chrony.git"
+ inherit git-r3
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/mlichvar.asc
+ inherit verify-sig
+
+ SRC_URI="https://download.tuxfamily.org/${PN}/${P/_/-}.tar.gz"
+ SRC_URI+=" verify-sig? ( https://download.tuxfamily.org/chrony/${P/_/-}-tar-gz-asc.txt -> ${P/_/-}.tar.gz.asc )"
+
+ if [[ ${PV} != *_pre* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ fi
+fi
+
+S="${WORKDIR}/${P/_/-}"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+caps +cmdmon debug html libtomcrypt +nettle nss +ntp +nts +phc pps +readline +refclock +rtc samba +seccomp +sechash selinux"
+# nettle > nss > libtomcrypt in configure
+REQUIRED_USE="
+ sechash? ( || ( nettle nss libtomcrypt ) )
+ nettle? ( !nss )
+ nss? ( !nettle )
+ libtomcrypt? ( !nettle !nss )
+ !sechash? ( !nss )
+ !sechash? ( !nts? ( !nettle ) )
+"
+
+DEPEND="
+ caps? (
+ acct-group/ntp
+ acct-user/ntp
+ sys-libs/libcap
+ )
+ nettle? ( dev-libs/nettle:= )
+ nss? ( dev-libs/nss:= )
+ nts? ( net-libs/gnutls:= )
+ pps? ( net-misc/pps-tools )
+ readline? ( dev-libs/libedit )
+ seccomp? ( sys-libs/libseccomp )
+"
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-chronyd )
+"
+# bison dep only for 4.3-r1 for ${P}-strict-prototypes-clang16.patch
+BDEPEND="
+ sys-devel/bison
+ html? ( dev-ruby/asciidoctor )
+ nts? ( virtual/pkgconfig )
+ sechash? (
+ nettle? ( virtual/pkgconfig )
+ nss? ( virtual/pkgconfig )
+ )
+"
+
+if [[ ${PV} == 9999 ]] ; then
+ # Needed for doc generation in 9999
+ REQUIRED_USE+=" html"
+ BDEPEND+="
+ sys-devel/bison
+ virtual/w3m
+ "
+else
+ BDEPEND+=" verify-sig? ( >=sec-keys/openpgp-keys-mlichvar-20210513 )"
+fi
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.5-pool-vendor-gentoo.patch
+ "${FILESDIR}"/${PN}-4.2-systemd-gentoo.patch
+ "${FILESDIR}"/${P}-strict-prototypes-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's:/etc/chrony\.conf:/etc/chrony/chrony.conf:g' \
+ doc/* examples/* || die
+
+ cp "${FILESDIR}"/chronyd.conf-r3 "${T}"/chronyd.conf || die
+}
+
+src_configure() {
+ if ! use caps ; then
+ sed -i \
+ -e 's/ -u ntp//' \
+ "${T}"/chronyd.conf examples/chronyd.service || die
+ fi
+
+ if ! use seccomp ; then
+ sed -i \
+ -e 's/ -F 2//' \
+ "${T}"/chronyd.conf examples/chronyd.service || die
+ fi
+
+ tc-export CC PKG_CONFIG
+
+ # Update from time to time with output from "date +%s"
+ # on a system that is time-synced.
+ export SOURCE_DATE_EPOCH=1607976314
+
+ # Not an autotools generated script
+ local myconf=(
+ $(use_enable seccomp scfilter)
+
+ $(usev !caps '--disable-linuxcaps')
+ $(usev !cmdmon '--disable-cmdmon')
+ $(usev debug '--enable-debug')
+
+ # USE=readline here means "readline-like functionality"
+ # chrony only supports libedit in terms of the library providing
+ # it.
+ $(usev !readline '--without-editline --disable-readline')
+
+ $(usev !libtomcrypt '--without-tomcrypt')
+ $(usev !nettle '--without-nettle')
+ $(usev !nss '--without-nss')
+ $(usev !ntp '--disable-ntp')
+ $(usev !nts '--disable-nts')
+ $(usev !nts '--without-gnutls')
+ $(usev !phc '--disable-phc')
+ $(usev !pps '--disable-pps')
+ $(usev !refclock '--disable-refclock')
+ $(usev !rtc '--disable-rtc')
+ $(usev samba '--enable-ntp-signd')
+ $(usev !sechash '--disable-sechash')
+
+ --chronysockdir="${EPREFIX}/run/chrony"
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --mandir="${EPREFIX}/usr/share/man"
+ --prefix="${EPREFIX}/usr"
+ --sysconfdir="${EPREFIX}/etc/chrony"
+ --with-hwclockfile="${EPREFIX}/etc/adjtime"
+ --with-pidfile="${EPREFIX}/run/chrony/chronyd.pid"
+
+ ${EXTRA_ECONF}
+ )
+
+ # Print the ./configure call
+ edo ./configure "${myconf[@]}" || die
+}
+
+src_compile() {
+ if [[ ${PV} == 9999 ]] ; then
+ # Uses w3m
+ emake -C doc man txt
+ fi
+
+ emake all docs $(usev !html 'ADOC=true')
+}
+
+src_install() {
+ default
+
+ # Compatibility with other distributions who install to /etc/chrony.conf (bug #835461)
+ dosym -r /etc/chrony/chrony.conf /etc/chrony.conf
+
+ newinitd "${FILESDIR}"/chronyd.init-r2 chronyd
+ newconfd "${T}"/chronyd.conf chronyd
+
+ insinto /etc/${PN}
+ newins examples/chrony.conf.example1 chrony.conf
+
+ docinto examples
+ dodoc examples/*.example*
+
+ newtmpfiles - chronyd.conf <<<"d /run/chrony 0750 $(usex caps 'ntp ntp' 'root root')"
+
+ if use html ; then
+ docinto html
+ dodoc doc/*.html
+ fi
+
+ keepdir /var/{lib,log}/chrony
+
+ if use caps ; then
+ # Prepare a directory for the chrony.drift file (a la ntpsec)
+ # Ensures the environment is sane on new installs
+ # bug #711058
+ fowners -R ntp:ntp /var/{lib,log}/chrony
+ fperms -R 770 /var/lib/chrony
+ fi
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/chrony-2.4-r1.logrotate chrony
+
+ systemd_dounit examples/chronyd.service
+ systemd_dounit examples/chrony-wait.service
+ systemd_enable_ntpunit 50-chrony chronyd.service
+}
+
+pkg_preinst() {
+ HAD_CAPS=0
+ HAD_SECCOMP=0
+ HAD_PRE_NEW_SECCOMP_LEVEL=0
+
+ # See https://dev.gentoo.org/~zmedico/portage/doc/portage.html#package-ebuild-phases-after-2.1.5
+ # in "Ebuild Phases" for an explanation of why we need to save the variable beforehand
+ if has_version 'net-misc/chrony[caps]' ; then
+ HAD_CAPS=1
+ fi
+
+ if has_version 'net-misc/chrony[seccomp]' ; then
+ HAD_SECCOMP=1
+ fi
+
+ if has_version '>=net-misc/chrony-4.1[seccomp]' ; then
+ # This version introduced a new filter level: -F 2
+ # It's a limited set of seccomp filters designed to be 'bare minimum'
+ HAD_PRE_NEW_SECCOMP_LEVEL=1
+ fi
+}
+
+pkg_postinst() {
+ tmpfiles_process chronyd.conf
+
+ if [[ -n "${REPLACING_VERSIONS}" ]] ; then
+ if use caps && ! [[ ${HAD_CAPS} -eq 1 ]] ; then
+ # bug #719876
+ ewarn "Please adjust permissions on ${EROOT}/var/{lib,log}/chrony to be owned by ntp:ntp"
+ ewarn "e.g. chown -R ntp:ntp ${EROOT}/var/{lib,log}/chrony"
+ ewarn "This is necessary for chrony to drop privileges"
+ elif ! use caps && [[ ${HAD_CAPS} -eq 0 ]] ; then
+ ewarn "Please adjust permissions on ${EROOT}/var/{lib,log}/chrony to be owned by root:root"
+ fi
+ fi
+
+ # See bug #783915 for general discussion on enabling seccomp filtering
+ # by default.
+ local show_seccomp_enable_msg=0
+
+ # Was seccomp disabled before and now enabled?
+ if [[ ${HAD_SECCOMP} -eq 0 ]] && use seccomp ; then
+ show_seccomp_enable_msg=1
+ fi
+
+ # Are we coming from an old version without the new 'minimal' filter?
+ # (-F 2)
+ if [[ ${HAD_PRE_NEW_SECCOMP_LEVEL} -eq 0 ]] ; then
+ show_seccomp_enable_msg=1
+ fi
+
+ if [[ ${show_seccomp_enable_msg} -eq 1 ]] ; then
+ elog "To enable seccomp in a stricter mode, please modify:"
+ elog "- ${EROOT}/etc/conf.d/chronyd for OpenRC"
+ elog "- systemctl edit chronyd for systemd"
+ elog "to use -F 1 or -F -1 instead of -F 2 (see man chronyd)"
+ elog "By default, we now use -F 2 which is a baseline/minimal filter."
+ fi
+}
diff --git a/net-misc/chrony/chrony-9999.ebuild b/net-misc/chrony/chrony-9999.ebuild
index e89af76426c6..64fe1397809a 100644
--- a/net-misc/chrony/chrony-9999.ebuild
+++ b/net-misc/chrony/chrony-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,7 +27,7 @@ S="${WORKDIR}/${P/_/-}"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+caps +cmdmon debug html ipv6 libtomcrypt +nettle nss +ntp +nts +phc pps +readline +refclock +rtc samba +seccomp +sechash selinux"
+IUSE="+caps +cmdmon debug html libtomcrypt +nettle nss +ntp +nts +phc pps +readline +refclock +rtc samba +seccomp +sechash selinux"
# nettle > nss > libtomcrypt in configure
REQUIRED_USE="
sechash? ( || ( nettle nss libtomcrypt ) )
@@ -78,6 +78,7 @@ fi
PATCHES=(
"${FILESDIR}"/${PN}-3.5-pool-vendor-gentoo.patch
"${FILESDIR}"/${PN}-4.2-systemd-gentoo.patch
+ "${FILESDIR}"/${P}-strict-prototypes-clang16.patch
)
src_prepare() {
@@ -116,7 +117,6 @@ src_configure() {
$(usev !caps '--disable-linuxcaps')
$(usev !cmdmon '--disable-cmdmon')
$(usev debug '--enable-debug')
- $(usev !ipv6 '--disable-ipv6')
# USE=readline here means "readline-like functionality"
# chrony only supports libedit in terms of the library providing
@@ -163,6 +163,9 @@ src_compile() {
src_install() {
default
+ # Compatibility with other distributions who install to /etc/chrony.conf (bug #835461)
+ dosym -r /etc/chrony/chrony.conf /etc/chrony.conf
+
newinitd "${FILESDIR}"/chronyd.init-r2 chronyd
newconfd "${T}"/chronyd.conf chronyd