summaryrefslogtreecommitdiff
path: root/net-misc/buka/buka-3.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
commitbd7908c6630f38067350d396ac5d18c3cc2434a0 (patch)
tree3559b3e11424f5529527f2474d8a977a91ee3389 /net-misc/buka/buka-3.0.1.ebuild
parent8b2628ad8526c806375e7b157889e4274b70248b (diff)
gentoo resync : 29.10.2017
Diffstat (limited to 'net-misc/buka/buka-3.0.1.ebuild')
-rw-r--r--net-misc/buka/buka-3.0.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/buka/buka-3.0.1.ebuild b/net-misc/buka/buka-3.0.1.ebuild
new file mode 100644
index 000000000000..1aa8b0d6554b
--- /dev/null
+++ b/net-misc/buka/buka-3.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+COMMIT="45e6b32de708759a4e15181a8e2ad5de55cc78ef"
+S=${WORKDIR}/${P}-${COMMIT}
+
+DESCRIPTION="Download manga from buka.cn"
+HOMEPAGE="https://gitlab.com/drylemon/buka"
+SRC_URI="https://gitlab.com/drylemon/buka/repository/${PV}/archive.tar.gz?ref=${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/beautifulsoup
+ dev-python/requests
+ sys-process/parallel
+ net-misc/curl
+ dev-util/dialog"
+
+src_install() {
+ default
+ doman "${PN}.1"
+ dobin "${PN}" "${PN}-parse"
+}
+
+pkg_postinst() {
+ optfeature "pdf support" media-gfx/imagemagick
+ optfeature "cbz support" app-arch/zip
+}