summaryrefslogtreecommitdiff
path: root/net-misc/bgpq3/bgpq3-0.1.22.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/bgpq3/bgpq3-0.1.22.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/bgpq3/bgpq3-0.1.22.ebuild')
-rw-r--r--net-misc/bgpq3/bgpq3-0.1.22.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/bgpq3/bgpq3-0.1.22.ebuild b/net-misc/bgpq3/bgpq3-0.1.22.ebuild
new file mode 100644
index 000000000000..c2b0ceab0697
--- /dev/null
+++ b/net-misc/bgpq3/bgpq3-0.1.22.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Generate access-lists for Cisco/Juniper routers, successor of bgpq"
+HOMEPAGE="http://snar.spb.ru/prog/bgpq3/"
+SRC_URI="http://snar.spb.ru/prog/bgpq3/${P}.tgz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+src_prepare() {
+ # Respect CFLAGS
+ sed -i \
+ -e '/^CFLAGS=/s/-g //' \
+ -e '/^CFLAGS=/s/ -O0//' \
+ Makefile.in || die 'sed on Makefile.in failed'
+
+ epatch_user
+}
+
+src_install() {
+ dobin bgpq3
+ doman bgpq3.8
+ dodoc CHANGES
+ dohtml *.html
+}