summaryrefslogtreecommitdiff
path: root/net-misc/batctl/batctl-2022.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-04 14:05:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-04 14:05:21 +0100
commit9ec9cbf23e468492eab5e3a31836c699e8c5c534 (patch)
tree0b9e7c4efba878b19e0c88b7b657475c4cef06d9 /net-misc/batctl/batctl-2022.2.ebuild
parentb46abba85084f65c8b5d619bfc4e2c5373ad4067 (diff)
gentoo auto-resync : 04:08:2022 - 14:05:20
Diffstat (limited to 'net-misc/batctl/batctl-2022.2.ebuild')
-rw-r--r--net-misc/batctl/batctl-2022.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/batctl/batctl-2022.2.ebuild b/net-misc/batctl/batctl-2022.2.ebuild
new file mode 100644
index 000000000000..03a22398411e
--- /dev/null
+++ b/net-misc/batctl/batctl-2022.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="BATMAN advanced control and management tool"
+HOMEPAGE="https://www.open-mesh.org/"
+SRC_URI="https://downloads.open-mesh.org/batman/releases/batman-adv-${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="dev-libs/libnl:3"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if ! linux_config_exists || ! linux_chkconfig_present BATMAN_ADV; then
+ ewarn "batctl requires batman-adv kernel support"
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1 REVISION="gentoo-${PVR}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ dodoc README.rst
+}