summaryrefslogtreecommitdiff
path: root/net-misc/balance/balance-3.57-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /net-misc/balance/balance-3.57-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'net-misc/balance/balance-3.57-r1.ebuild')
-rw-r--r--net-misc/balance/balance-3.57-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/balance/balance-3.57-r1.ebuild b/net-misc/balance/balance-3.57-r1.ebuild
new file mode 100644
index 000000000000..bfbf74ec2a13
--- /dev/null
+++ b/net-misc/balance/balance-3.57-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps toolchain-funcs
+
+DESCRIPTION="TCP Load Balancing Port Forwarder"
+HOMEPAGE="http://www.inlab.de/balance.html"
+SRC_URI="http://www.inlab.de/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=( "${FILESDIR}"/${P}-Makefile.patch )
+
+FILECAPS=(
+ CAP_NET_BIND_SERVICE usr/sbin/balance
+)
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ default
+
+ # Autocreated on program start, if missing
+ rm -rv "${ED}/var/run" || die
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+ elog "To run as non-root, be sure to have rendezvous directory created"
+ elog "with either 'mkdir -m 01777 ${EROOT}/var/run/balance' or using tmpfiles."
+}