summaryrefslogtreecommitdiff
path: root/net-misc/axel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /net-misc/axel
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'net-misc/axel')
-rw-r--r--net-misc/axel/Manifest2
-rw-r--r--net-misc/axel/axel-2.17.9.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/axel/Manifest b/net-misc/axel/Manifest
index 12532183898b..121422764a4a 100644
--- a/net-misc/axel/Manifest
+++ b/net-misc/axel/Manifest
@@ -1,3 +1,5 @@
DIST axel-2.17.8.tar.xz 201224 BLAKE2B 0a10187013aa888ae8fa7f165b88955f5a7d63241157f552778c042eaecc7873e10e27537a8c7a26a09df5e655097845037f23a6c39f4d46328d633f944a316a SHA512 9158cc0f1c7b54d84e5c15331ddcf6056b5eb654c0ad068e058eedbea99bb87c1b2e759b57872a86d76d83d6807500989ad6bbf87f1c0210db2d4dab100933ea
+DIST axel-2.17.9.tar.xz 204212 BLAKE2B 8ec63a5ccf73bf8e17c559b7fbce08ee926b0001b1d6f8ea09cbe1a7c600ceba69b6b6ecd19f989da333b57ed11e9a93913b2fa520d7e56b7d796cf18dcb9f1a SHA512 a0cabf43f451d61f4b1f4892a381fd5cf4088f7148502bf4e27d1c98177c3777bab9b732780cb9ba60c45aeead6cf9b79f870ac16db7148180f26350e69d8b01
EBUILD axel-2.17.8.ebuild 1054 BLAKE2B 4b125d7d707116374d3c66342a70d174eee139e5f5ba07ef3d9b7bd8d2da2a2c906aceea4b751977c8bedf626d5bdef54b11263140d663f5559cc92b67702b44 SHA512 982df8b1fe6e40cda200318ecb32058c9d31889a8473f7124651353e0897b79729f4d3cd4697957a1047dd3a12890ad492481f3118a2539c3577e95bc7d0dcf9
+EBUILD axel-2.17.9.ebuild 1059 BLAKE2B e30d0a04e6d39c123c72ae51de2db98dc3cb9661010452a699139d40a03216dd788ccaff6e2e57230cedb104bcf992f0b224c62866e61b41afd1bbafdbc3b8c2 SHA512 b1b03f38c0c126b422732ae3cfe278b2270f46e812179aae7c2d2b68ed44fd544af0183291e17ac83474f45f62014ff0d4f6220d79f0ef41251c6e29900a6936
MISC metadata.xml 410 BLAKE2B 89c374385d4e3a03953352d1d995029ca481386a0c522b1c4c2c18bc58c62f65e5eb287a656392093d72735174adc8e48dacd1771989d0bdd6ca2a0c77e3cd80 SHA512 f64c314f27882031b215373ded6b4a1e0a93b398ec96aff1a429ef6b01cc1d426c1692b8f2ecdea4f5503d853d753f292a7edac960a559bcb60ea491d5a1e7ce
diff --git a/net-misc/axel/axel-2.17.9.ebuild b/net-misc/axel/axel-2.17.9.ebuild
new file mode 100644
index 000000000000..dad9472d9679
--- /dev/null
+++ b/net-misc/axel/axel-2.17.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Light Unix download accelerator"
+HOMEPAGE="https://github.com/axel-download-accelerator/axel"
+SRC_URI="https://github.com/axel-download-accelerator/axel/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug libressl nls ssl"
+
+CDEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+DEPEND="${CDEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${CDEPEND}
+ nls? ( virtual/libintl virtual/libiconv )"
+
+DOCS=( doc/. )
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with ssl)
+}
+
+pkg_postinst() {
+ einfo 'To use axel with Portage, one can configure make.conf with:'
+ einfo
+ einfo 'FETCHCOMMAND="axel --timeout=30 --alternate --no-clobber --output=\"\${DISTDIR}/\${FILE}\" \"\${URI}\""'
+ einfo 'RESUMECOMMAND="axel --timeout=30 --alternate --no-clobber --output=\"\${DISTDIR}/\${FILE}\" \"\${URI}\""'
+}