summaryrefslogtreecommitdiff
path: root/net-misc/autoupnp/autoupnp-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-12 09:31:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-12 09:31:41 +0000
commit983485e93d76602266889d23c963609073b75e51 (patch)
tree19081a3616b34ff1d8bc5521d767740501b31153 /net-misc/autoupnp/autoupnp-0.5.0.ebuild
parent3a9a4f8b478ff62e3c752e20305edb2c7d91959f (diff)
gentoo auto-resync : 12:11:2022 - 09:31:40
Diffstat (limited to 'net-misc/autoupnp/autoupnp-0.5.0.ebuild')
-rw-r--r--net-misc/autoupnp/autoupnp-0.5.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/autoupnp/autoupnp-0.5.0.ebuild b/net-misc/autoupnp/autoupnp-0.5.0.ebuild
new file mode 100644
index 000000000000..9f5acac5c152
--- /dev/null
+++ b/net-misc/autoupnp/autoupnp-0.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Automatic open port forwarder using UPnP"
+HOMEPAGE="https://github.com/projg2/autoupnp/"
+SRC_URI="
+ https://github.com/projg2/autoupnp/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+DEPEND="
+ net-libs/miniupnpc:0=
+ libnotify? ( x11-libs/libtinynotify:0= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature libnotify)
+ )
+ meson_src_configure
+}