summaryrefslogtreecommitdiff
path: root/net-misc/autoupnp/autoupnp-0.4.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/autoupnp/autoupnp-0.4.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/autoupnp/autoupnp-0.4.7.ebuild')
-rw-r--r--net-misc/autoupnp/autoupnp-0.4.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/autoupnp/autoupnp-0.4.7.ebuild b/net-misc/autoupnp/autoupnp-0.4.7.ebuild
new file mode 100644
index 000000000000..88e67f8857d4
--- /dev/null
+++ b/net-misc/autoupnp/autoupnp-0.4.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Automatic open port forwarder using UPnP"
+HOMEPAGE="https://bitbucket.org/mgorny/autoupnp/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="net-libs/miniupnpc:0=
+ libnotify? ( x11-libs/libtinynotify:0= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myconf=(
+ $(use_with libnotify)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}