summaryrefslogtreecommitdiff
path: root/net-misc/autossh/autossh-1.4g-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-12 05:48:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-12 05:48:13 +0100
commit8d9dd6a2b8f0525f6337deacd0cc20027f645396 (patch)
tree055778f8b0feeae92daec20b5693a21a206ea379 /net-misc/autossh/autossh-1.4g-r2.ebuild
parent02930d1eb5af78d32b1597af6af24163895d9e0f (diff)
gentoo auto-resync : 12:05:2023 - 05:48:13
Diffstat (limited to 'net-misc/autossh/autossh-1.4g-r2.ebuild')
-rw-r--r--net-misc/autossh/autossh-1.4g-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/autossh/autossh-1.4g-r2.ebuild b/net-misc/autossh/autossh-1.4g-r2.ebuild
new file mode 100644
index 000000000000..d792505d9987
--- /dev/null
+++ b/net-misc/autossh/autossh-1.4g-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Automatically restart SSH sessions and tunnels"
+HOMEPAGE="https://www.harding.motd.ca/autossh/"
+SRC_URI="https://www.harding.motd.ca/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+DEPEND="dev-libs/libbsd"
+RDEPEND="${DEPEND}
+ virtual/openssh"
+
+PATCHES=(
+ "${FILESDIR}"/autossh-1.4g-libbsd.patch
+ "${FILESDIR}"/autossh-1.4g-printf.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ dobin autossh
+ dodoc CHANGES README autossh.host rscreen
+ doman autossh.1
+}