summaryrefslogtreecommitdiff
path: root/net-misc/astmanproxy/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /net-misc/astmanproxy/files
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'net-misc/astmanproxy/files')
-rw-r--r--net-misc/astmanproxy/files/astmanproxy-1.28.2-fno-common.patch11
-rw-r--r--net-misc/astmanproxy/files/astmanproxy-1.28.2-gentoo.diff32
2 files changed, 34 insertions, 9 deletions
diff --git a/net-misc/astmanproxy/files/astmanproxy-1.28.2-fno-common.patch b/net-misc/astmanproxy/files/astmanproxy-1.28.2-fno-common.patch
new file mode 100644
index 000000000000..a7fb09687702
--- /dev/null
+++ b/net-misc/astmanproxy/files/astmanproxy-1.28.2-fno-common.patch
@@ -0,0 +1,11 @@
+--- a/src/include/astmanproxy.h
++++ b/src/include/astmanproxy.h
+@@ -154,7 +154,7 @@ struct message {
+ struct mansession *session;
+ };
+
+-struct proxyconfig pc;
++extern struct proxyconfig pc;
+ extern int debug;
+
+ /* Common Function Prototypes */
diff --git a/net-misc/astmanproxy/files/astmanproxy-1.28.2-gentoo.diff b/net-misc/astmanproxy/files/astmanproxy-1.28.2-gentoo.diff
index 68534cd61086..c6696fedf4a1 100644
--- a/net-misc/astmanproxy/files/astmanproxy-1.28.2-gentoo.diff
+++ b/net-misc/astmanproxy/files/astmanproxy-1.28.2-gentoo.diff
@@ -1,21 +1,23 @@
-diff -uNr astmanproxy-1.28.2.ORIG/Makefile astmanproxy-1.28.2/Makefile
---- astmanproxy-1.28.2.ORIG/Makefile 2014-02-10 11:18:06.027132570 +0000
-+++ astmanproxy-1.28.2/Makefile 2014-02-10 11:21:07.382135291 +0000
-@@ -17,7 +17,7 @@
+--- a/Makefile
++++ b/Makefile
+@@ -15,9 +15,8 @@
+ CONFFILE := astmanproxy.conf
+ PERMFILE := astmanproxy.users
- CC := gcc
+-CC := gcc
INCLUDES :=
-PREFIX:= /usr/local
+PREFIX:= /usr
BINDIR := $(DESTDIR)$(PREFIX)/sbin
# For compilation dependencies
-@@ -27,7 +27,7 @@
+@@ -27,7 +26,8 @@
LIBS := -lssl
# Add -g below for debug/GDB symbols
-CFLAGS:=-Wall -O2 -D_REENTRANT -D_GNU_SOURCE -fPIC -Isrc/include -I/usr/include/openssl
-+CFLAGS += -Wall -O2 -D_REENTRANT -D_GNU_SOURCE -fPIC -Isrc/include -I/usr/include/openssl
++CFLAGS += -Wall -fPIC
++CPPFLAGS += -D_REENTRANT -D_GNU_SOURCE -Isrc/include -I/usr/include/openssl
ifeq (${OSARCH},Darwin)
LIBS+=-lresolv
@@ -28,7 +30,7 @@ diff -uNr astmanproxy-1.28.2.ORIG/Makefile astmanproxy-1.28.2/Makefile
CFLAGS += $(DEFINES)
-@@ -76,7 +76,7 @@
+@@ -76,16 +76,16 @@
SRCS := $(MODS:%=src/%.c)
HDRS := src/include/astmanproxy.h
@@ -36,4 +38,16 @@ diff -uNr astmanproxy-1.28.2.ORIG/Makefile astmanproxy-1.28.2/Makefile
+all: astmanproxy
astmanproxy: $(OBJS) $(SOBJS)
- $(CC) $(CFLAGS) -o $@ $(ASTLINK) $(OBJS) $(LIBS)
+- $(CC) $(CFLAGS) -o $@ $(ASTLINK) $(OBJS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(ASTLINK) $(OBJS) $(LIBS)
+
+ $(OBJS): %.o: %.c
+- $(CC) $(CFLAGS) $(INCLUDES) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(INCLUDES) -c -o $@ $<
+
+ $(SOBJS): %.so: %.o
+- $(CC) $(SOLINK) $< -o $@
++ $(CC) $(LDFLAGS) $(SOLINK) $< -o $@
+
+ SERIAL=`date "+%Y%m%d%H%M%S"`
+