summaryrefslogtreecommitdiff
path: root/net-misc/astmanproxy/files/astmanproxy-1.28.2-gentoo.diff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/astmanproxy/files/astmanproxy-1.28.2-gentoo.diff
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/astmanproxy/files/astmanproxy-1.28.2-gentoo.diff')
-rw-r--r--net-misc/astmanproxy/files/astmanproxy-1.28.2-gentoo.diff39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/astmanproxy/files/astmanproxy-1.28.2-gentoo.diff b/net-misc/astmanproxy/files/astmanproxy-1.28.2-gentoo.diff
new file mode 100644
index 000000000000..68534cd61086
--- /dev/null
+++ b/net-misc/astmanproxy/files/astmanproxy-1.28.2-gentoo.diff
@@ -0,0 +1,39 @@
+diff -uNr astmanproxy-1.28.2.ORIG/Makefile astmanproxy-1.28.2/Makefile
+--- astmanproxy-1.28.2.ORIG/Makefile 2014-02-10 11:18:06.027132570 +0000
++++ astmanproxy-1.28.2/Makefile 2014-02-10 11:21:07.382135291 +0000
+@@ -17,7 +17,7 @@
+
+ CC := gcc
+ INCLUDES :=
+-PREFIX:= /usr/local
++PREFIX:= /usr
+ BINDIR := $(DESTDIR)$(PREFIX)/sbin
+
+ # For compilation dependencies
+@@ -27,7 +27,7 @@
+ LIBS := -lssl
+
+ # Add -g below for debug/GDB symbols
+-CFLAGS:=-Wall -O2 -D_REENTRANT -D_GNU_SOURCE -fPIC -Isrc/include -I/usr/include/openssl
++CFLAGS += -Wall -O2 -D_REENTRANT -D_GNU_SOURCE -fPIC -Isrc/include -I/usr/include/openssl
+
+ ifeq (${OSARCH},Darwin)
+ LIBS+=-lresolv
+@@ -62,7 +62,7 @@
+ DEFINES+='-DMDIR="$(MODDIR)"' '-DPDIR="$(PERMDIR)"' '-DPFILE="$(PERMFILE)"'
+
+ PROXYCERT := $(CERTDIR)/proxy-server.pem
+-PROXYSSLCONF := $(CONFDIR)/proxy-ssl.conf
++PROXYSSLCONF := $(DESTDIR)$(CONFDIR)/proxy-ssl.conf
+
+ CFLAGS += $(DEFINES)
+
+@@ -76,7 +76,7 @@
+ SRCS := $(MODS:%=src/%.c)
+ HDRS := src/include/astmanproxy.h
+
+-all: astmanproxy cert
++all: astmanproxy
+
+ astmanproxy: $(OBJS) $(SOBJS)
+ $(CC) $(CFLAGS) -o $@ $(ASTLINK) $(OBJS) $(LIBS)