summaryrefslogtreecommitdiff
path: root/net-misc/anydesk/anydesk-6.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-26 20:52:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-26 20:52:48 +0100
commit0e83ee97d831abe38c8e764fb9bbfef9de04daf2 (patch)
treefca9d00e42cd967e466d66fd8d23d3bcee39cf75 /net-misc/anydesk/anydesk-6.1.0.ebuild
parentc3d998909264b1ff687b9c65cae3046443e66f7e (diff)
gentoo auto-resync : 26:08:2022 - 20:52:47
Diffstat (limited to 'net-misc/anydesk/anydesk-6.1.0.ebuild')
-rw-r--r--net-misc/anydesk/anydesk-6.1.0.ebuild109
1 files changed, 0 insertions, 109 deletions
diff --git a/net-misc/anydesk/anydesk-6.1.0.ebuild b/net-misc/anydesk/anydesk-6.1.0.ebuild
deleted file mode 100644
index 258fe9e1b0d6..000000000000
--- a/net-misc/anydesk/anydesk-6.1.0.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit desktop optfeature systemd xdg-utils
-
-DESCRIPTION="Feature rich multi-platform remote desktop application"
-HOMEPAGE="https://anydesk.com"
-SRC_URI="https://download.anydesk.com/linux/${P}-amd64.tar.gz
- https://download.anydesk.com/linux/generic-linux/${P}-amd64.tar.gz"
-
-# OpeSSL/SSLeay, libvpx, zlib, Xiph, xxHash
-LICENSE="AnyDesk-TOS BSD BSD-2 openssl ZLIB"
-SLOT="0"
-KEYWORDS="-* ~amd64"
-
-RDEPEND="
- dev-libs/atk
- dev-libs/glib:2
- media-libs/fontconfig:1.0
- media-libs/freetype:2
- media-libs/glu
- media-libs/mesa[X(+)]
- sys-auth/polkit
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:2
- x11-libs/gtkglext
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libxcb
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXi
- x11-libs/libxkbfile
- x11-libs/libXmu
- x11-libs/libXrandr
- x11-libs/libXrender
- x11-libs/libXt
- x11-libs/libXtst
- x11-libs/pango
-"
-BDEPEND="dev-util/patchelf"
-
-RESTRICT="bindist mirror"
-
-QA_PREBUILT="opt/${PN}/*"
-
-src_install() {
- local dst="/opt/${PN}"
-
- exeinto ${dst}
- doexe ${PN}
-
- # bug 706344
- patchelf --remove-needed libpangox-1.0.so.0 "${ED}${dst}/${PN}" || die
-
- dodir /opt/bin
- dosym "${dst}/${PN}" "/opt/bin/${PN}"
-
- newinitd "${FILESDIR}/anydesk.init" anydesk
- systemd_newunit "${FILESDIR}/anydesk-4.0.1.service" anydesk.service
-
- insinto /usr/share/polkit-1/actions
- doins polkit-1/com.philandro.anydesk.policy
-
- insinto /usr/share
- doins -r icons
-
- domenu "${FILESDIR}/anydesk.desktop"
-
- keepdir "/etc/${PN}"
-
- dodoc copyright README
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "To run AnyDesk as background service use:"
- elog
- elog "OpenRC:"
- elog "# rc-service anydesk start"
- elog "# rc-update add anydesk default"
- elog
- elog "Systemd:"
- elog "# systemctl start anydesk.service"
- elog "# systemctl enable anydesk.service"
- elog
- elog "Please see README at /usr/share/doc/${PF}/README.bz2 for"
- elog "further information about the linux version of AnyDesk."
- elog
- fi
-
- optfeature_header "AnyDesk uses additional tools to query information about the host:"
- optfeature "lsb_release" sys-apps/lsb-release
- optfeature "lspci" sys-apps/pciutils
- optfeature "lsusb" sys-apps/usbutils
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}