summaryrefslogtreecommitdiff
path: root/net-misc/AQtion
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /net-misc/AQtion
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'net-misc/AQtion')
-rw-r--r--net-misc/AQtion/AQtion-2.2.7.ebuild49
-rw-r--r--net-misc/AQtion/Manifest3
-rw-r--r--net-misc/AQtion/metadata.xml24
3 files changed, 76 insertions, 0 deletions
diff --git a/net-misc/AQtion/AQtion-2.2.7.ebuild b/net-misc/AQtion/AQtion-2.2.7.ebuild
new file mode 100644
index 000000000000..157bb239defb
--- /dev/null
+++ b/net-misc/AQtion/AQtion-2.2.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod
+
+DESCRIPTION="Aquantia AQC multigigabit NIC linux driver (atlantic) - development preview"
+HOMEPAGE="https://github.com/Aquantia/AQtion"
+
+COMMIT_ID="e024a859ea828ced78db310328db90dbedea837a"
+SRC_URI="https://github.com/Aquantia/${PN}/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="lro"
+
+DEPEND="virtual/linux-sources"
+
+S="${WORKDIR}/${PN}-${COMMIT_ID}"
+
+MODULE_NAMES="atlantic(drivers/net/ethernet/aquantia/atlantic:${S})"
+BUILD_TARGETS="all"
+CONFIG_CHECK="~!AQTION ~PTP_1588_CLOCK ~CRC_ITU_T"
+
+DOCS=(
+ README.md
+ README.txt
+)
+
+pkg_setup() {
+ use lro && CONFIG_CHECK+=" ~!CONFIG_BRIDGE"
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if ! use lro; then
+ sed -r -i -e 's/(#define AQ_CFG_IS_LRO_DEF[[:space:]]+)[[:digit:]]+([[:alpha:]]*)/\10\2/' \
+ aq_cfg.h || die
+ fi
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc "${DOCS[@]}"
+}
diff --git a/net-misc/AQtion/Manifest b/net-misc/AQtion/Manifest
new file mode 100644
index 000000000000..c9aa8208c79f
--- /dev/null
+++ b/net-misc/AQtion/Manifest
@@ -0,0 +1,3 @@
+DIST AQtion-2.2.7.tar.gz 122679 BLAKE2B 9d4e2d4d4b26a191551e2cfd30c2a8ce4e4bde01b7ab1e9beb9564abdfd1093b63f94713570fe2c949943037b649c55a9f448b0333fcdcc7227849330d466f92 SHA512 d3ba78acbe5d85d1017d5460fa7d916ffa59eeb137aa1817da215f08b994a10336a9f865c9b84a16b8cef7238d4fd87785bc17d6e3eac577210bf321538cbda3
+EBUILD AQtion-2.2.7.ebuild 1011 BLAKE2B c7210658ee6823245bfcc3b44252228e913f0c38d7a7180d5c65d0effb830ffc37950216d6f56685fb181c78cc27e33fbfa437e57100f5108c3baac0c8a7a9ef SHA512 938ca7011bf9952768306b8f26ccc24b1dd73c48cb3cba6991e2bc8b5ab282b99def15bbe4bb37978f29849a961cb0527f8e5f408f600b4c2045fa74e512cdb8
+MISC metadata.xml 697 BLAKE2B 2462c0dedde087805f1879750ad183a9c5d29dbd8561270f9e999bda47946517ce45ab70d29851aec06b5f2e79aa93fa5f7d9f09bcb3f089bf4cada541c4b87a SHA512 f2cbb250acd2690842dbdb5645f04e071f08a65e9dd80153fef3fe1c5d35ea1b5c40e8c58309b9323ca53941e902069c11b710037289923ff2b9a77570cb8313
diff --git a/net-misc/AQtion/metadata.xml b/net-misc/AQtion/metadata.xml
new file mode 100644
index 000000000000..62085b44d7b0
--- /dev/null
+++ b/net-misc/AQtion/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Aquantia/AQtion</remote-id>
+ </upstream>
+ <use>
+ <flag name="lro">
+ Enable/disable Large Receive Offload. This MUST be disabled for
+ bridging or forwarding.
+ </flag>
+ </use>
+ <longdescription>
+ Latest development preview of aquantia's atlantic linux kernel
+ driver for AQtion family of multigigabit adapters.
+
+ These drivers are UNSUPPORTED by the vendor, use at your own
+ risk.
+ </longdescription>
+</pkgmetadata>