summaryrefslogtreecommitdiff
path: root/net-mail
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-26 23:59:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-26 23:59:37 +0100
commit3e42d1577189af123b773dc0f11e5419035308c8 (patch)
tree95d77507c924544b12363e6da6aa741c444f3e8a /net-mail
parent6243676c91946098c06d42bc87b5eb99aac40bf0 (diff)
gentoo auto-resync : 26:04:2024 - 23:59:36
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/Manifest.gzbin14056 -> 14057 bytes
-rw-r--r--net-mail/mailbox-count/Manifest4
-rw-r--r--net-mail/mailbox-count/mailbox-count-0.0.8.ebuild37
-rw-r--r--net-mail/mailbox-count/metadata.xml4
4 files changed, 42 insertions, 3 deletions
diff --git a/net-mail/Manifest.gz b/net-mail/Manifest.gz
index 91a3d20f793c..4cc1763d075c 100644
--- a/net-mail/Manifest.gz
+++ b/net-mail/Manifest.gz
Binary files differ
diff --git a/net-mail/mailbox-count/Manifest b/net-mail/mailbox-count/Manifest
index ecce2d95cfd3..9f71574704e4 100644
--- a/net-mail/mailbox-count/Manifest
+++ b/net-mail/mailbox-count/Manifest
@@ -1,3 +1,5 @@
DIST mailbox-count-0.0.6.tar.gz 21176 BLAKE2B 655815d463e14ee8c32cc955819d6b95d5359a644fb09433cb8ab303f07a98ce33b4c048be724253f30d8855a921abb5a7a29e62391ef8a1a9288e2f430710fc SHA512 285aeeaa8cfaade6c91a850154772e47aa212f73d1206c3c8262d08a15b95f15ce812152ca5acf79f5390f476ed6af52a73e03af4ab297e1268044a4a9ece6b5
+DIST mailbox-count-0.0.8.tar.gz 21179 BLAKE2B 09577d00716f872fbc07dd6b2ad2225a2e11c4bccb68bd22de9e9d78aa334fdece20654e9a5ea91b85d87c4204808693b7efc4eb2375691958bee69814ae5c34 SHA512 2be8d09b241b7a4fb5156e8051227fd87a6df9c8f84e9a14b6f6796a64963ba5e65fd3b96954fc0bfba4c93318dbc06528c771b568c94a1848b0905be466ff1f
EBUILD mailbox-count-0.0.6.ebuild 909 BLAKE2B 1c4d5e6e76fe42ed08606e76aad0fc1ec75b29dd7de70f21f641ea0070a6e3fa3098e5d53af8a2c888e4bd66304c486cc1fe5ff22d221eb835538e5efd81799e SHA512 93b965b5d38edf94863fec72fa221bc91ff71c688b7b8ba8bedfb3d1879d50e933db5dfedafe1a92b7b9386aefc367151c58e92e501fb876509258da4cb6f0fc
-MISC metadata.xml 1059 BLAKE2B edbab64630a76439222edc42778fd497de925c8e8c5817da4be3f978c582149d62c369828421d36f0969a2dfa4d87255acf601bf73d339acfea30fe8f1708543 SHA512 9eae87b53f29f2909be1e862b9f811a946f32b271fab52513a6322533b9aa9d0c0738ca8548c4350282fb3bbb879305f7fb82ae662bd9982f851b72eff7315c2
+EBUILD mailbox-count-0.0.8.ebuild 909 BLAKE2B c1622d809f88a27c43a015b7a504bf6281292e0ea09519b81ff9484995d3240d49637fecd2b79cb775259dce128ae48db124d8542145f7ea9cf7da1145c2219e SHA512 96aa013c1c4d1bdf94ecd3cbb34fe02fcc0b22272239c201d8ab5c5b88cf3bd5c8292a3ab4255b6a6d5b3317d4efa955b06aecf7524673ce2b4d1dd986e606d5
+MISC metadata.xml 1065 BLAKE2B 50cca90f0e40eb1765cab18cb77065538b96e7594b4901faaf0b020c88fe3da48fcd7efca6ee007482c9539544fd6b1093be98e75f1d64e244f9be86cb281bbc SHA512 6da68a618fead3ca34462c67b94fbeba62dde99196fa7772b50f9f92b4a342d2515efd17d0a8117f0c3b7fcde5a1dd0c327ec7e5463307a009c8bc5e63f70ef2
diff --git a/net-mail/mailbox-count/mailbox-count-0.0.8.ebuild b/net-mail/mailbox-count/mailbox-count-0.0.8.ebuild
new file mode 100644
index 000000000000..c2af7578eb1c
--- /dev/null
+++ b/net-mail/mailbox-count/mailbox-count-0.0.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Count mailboxes in a SQL database"
+HOMEPAGE="https://michael.orlitzky.com/code/mailbox-count.xhtml"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/cmdargs-0.10
+ >=dev-haskell/configurator-0.2
+ >=dev-haskell/hdbc-2.4
+ >=dev-haskell/hdbc-postgresql-2.3
+ >=dev-haskell/hdbc-sqlite3-2.3
+ >=dev-haskell/missingh-1.2
+ >=dev-haskell/tasty-0.8
+ >=dev-haskell/tasty-hunit-0.8
+ >=dev-lang/ghc-9.0
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0
+ test? ( >=dev-haskell/doctest-0.9
+ >=dev-haskell/filemanip-0.3.6 )"
+
+src_install() {
+ haskell-cabal_src_install
+ dodoc "${S}/doc/${PN}rc.example"
+ doman "${S}/doc/man1/${PN}.1"
+}
diff --git a/net-mail/mailbox-count/metadata.xml b/net-mail/mailbox-count/metadata.xml
index 134a467564f6..93e079338c31 100644
--- a/net-mail/mailbox-count/metadata.xml
+++ b/net-mail/mailbox-count/metadata.xml
@@ -13,12 +13,12 @@
Mailbox-count produces a simple count of mailboxes that exist
per-domain in some SQL database. The default queries are compatible
with the schema used by PostfixAdmin but it is possible to supply
- your own queries via the --summary-query and --detail-query options.
+ your own queries either on the command-line or in a configuration
+ file.
The summary report lists each domain, along with the number of
mailboxes owned by that domain. The order is determined by the
summary query, which lists the domains alphabetically by default.
-
The default detail report shows the same, but also contains a list
of each individual mailbox (again in alphabetical order) belonging
to the domains.