summaryrefslogtreecommitdiff
path: root/net-mail
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-01 08:00:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-01 08:00:51 +0100
commitd1c14e94a73fba924761cdad7298f3e48c6bc160 (patch)
tree60b97f0d81b3b06b06acc48ff8856d7c4afa2989 /net-mail
parentd5ee59790ee8298b8599b0aa0fa21a98b972a44d (diff)
gentoo auto-resync : 01:07:2024 - 08:00:50
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/Manifest.gzbin14049 -> 14051 bytes
-rw-r--r--net-mail/swaks/Manifest4
-rw-r--r--net-mail/swaks/metadata.xml3
-rw-r--r--net-mail/swaks/swaks-20240103.0.ebuild46
4 files changed, 52 insertions, 1 deletions
diff --git a/net-mail/Manifest.gz b/net-mail/Manifest.gz
index df66bdea1004..f9c9fbcd7368 100644
--- a/net-mail/Manifest.gz
+++ b/net-mail/Manifest.gz
Binary files differ
diff --git a/net-mail/swaks/Manifest b/net-mail/swaks/Manifest
index 235116da7cda..82014c25a79c 100644
--- a/net-mail/swaks/Manifest
+++ b/net-mail/swaks/Manifest
@@ -1,3 +1,5 @@
DIST swaks-20201014.0.tar.gz 110953 BLAKE2B 8dd2c681c6c1e66b76bda71f0bc8b88e658565b28c29ae9f02e5c27500619598e5817a442aa82c48fd90be80cd2dc54eda8390ad3d1cb2e00163cc07a526f463 SHA512 8a4e8dc810a9c5943afdbc4db7130e110c42e211d6927ce1cdbab6f81fa49c31490e6c3668ec3cea79580c07b281ce30901b3b4a71325951167158cc9d70d9cc
+DIST swaks-20240103.0.tar.gz 121308 BLAKE2B 7146c17181c854a474a57e3fc4d2337af910159802c6c2137b48bfb03d54579835b9eecb987874e122ae793c15e3718efd1f1962dc5508878b59afbc5182b658 SHA512 89d62cdb94630666c1acb1feb3b62585f36b4d59d14e56d998da6efe45538e9f5072379eebee43dd7244aa3981dbd8d6eb9a42ff7fa21a73127d171b8b3189f5
EBUILD swaks-20201014.0.ebuild 1078 BLAKE2B 5d1a303abf92edebf666d7431622605800e277def961ecf76630eabf503102f39cca47717542310aaf86db41930eb705f8c75c00e1a826eb2d9ab0b6665b0fb5 SHA512 b49417a20f738ccfa589b61dd59c942f8cad85f9edf865fdbfd96f919f1eb07356a481b9f035cd7825b2051d89fff549e89a7b6537208d5ac0ed4b5b24f9e7c1
-MISC metadata.xml 571 BLAKE2B b3cba19bab9c116897cc6e81adc9ee43dc6463e9e5517d1de1d0090208d8849b6e1723f9777de2f865dc1cdb514ba6a1de0bbf9a07bc7448c523fe6dc56d67eb SHA512 601e7bfbbcf8c676734ae69dc3a04fd277e62ee6e80307db565583c61949e1c0fbb72ffc968d671289b7e20a021b41a1ef13916ca15d2d34ea98aeeab70b6b1b
+EBUILD swaks-20240103.0.ebuild 1468 BLAKE2B b3b8df13b37832d1016942ed9d1754e706e3d4f50e3c6424e3626648c395d218e9ca8abff45b482c147516726dd9f937acf0e57a68a53dc4d548c8094a8da5cf SHA512 2a9bbf87055289714111447e5c5c22901875373fc71287bba0ae6af134ebd712316015d28b1874894dc1901c42204f1d1caecb099a85fd43145eed4c5522c04d
+MISC metadata.xml 649 BLAKE2B bd1b2732babd17766d30f6eee17bffa718f12b0dd683753afee45c8c24e16425388efecb39b7551c5efdd0ac4710f81feb80c39456f6e0ce929080b304b0aa2a SHA512 061d2beaaf19388adddfeb416ca8d4ae96a07f23a4a62362aa3e0091b60ea38276221c2f34cb6c1a8bbd9772510c30ca139820128b397509801a53a7b229cbe6
diff --git a/net-mail/swaks/metadata.xml b/net-mail/swaks/metadata.xml
index 1067669574a5..07083b63ff28 100644
--- a/net-mail/swaks/metadata.xml
+++ b/net-mail/swaks/metadata.xml
@@ -13,4 +13,7 @@
"Swiss Army Knife SMTP; Command line SMTP testing, including TLS and
AUTH" - a full-featured Perl script for testing SMTP servers.
</longdescription>
+ <upstream>
+ <remote-id type="github">jetmore/swaks</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/net-mail/swaks/swaks-20240103.0.ebuild b/net-mail/swaks/swaks-20240103.0.ebuild
new file mode 100644
index 000000000000..3d4d0004140b
--- /dev/null
+++ b/net-mail/swaks/swaks-20240103.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Swiss Army Knife SMTP; Command line SMTP testing, including TLS and AUTH"
+HOMEPAGE="https://www.jetmore.org/john/code/swaks/
+ https://github.com/jetmore/swaks"
+SRC_URI="https://www.jetmore.org/john/code/swaks/${P}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+
+RDEPEND="
+ virtual/perl-Getopt-Long
+"
+BDEPEND="app-text/txt2man"
+
+src_compile() {
+ txt2man -s 1 -t "swaks" -v "Mail tools" doc/ref.txt \
+ > swaks.1 \
+ || die "man page compilation failed"
+}
+
+src_install() {
+ dobin swaks
+ doman swaks.1
+ dodoc README.txt doc/*.txt
+}
+
+pkg_postinst() {
+ # See https://github.com/jetmore/swaks/blob/v20240103.0/swaks#L1933-L1953
+ local header="Install the following additional packages for optional runtime features.\n"
+ header+="You may also check the output of 'swaks --support' to list currently available features:"
+ optfeature_header "$header"
+ optfeature "Basic auth support" virtual/perl-MIME-Base64
+ optfeature "AUTH CRAM-MD5 support" virtual/perl-Digest-MD5
+ optfeature "AUTH CRAM-SHA1 support" virtual/perl-Digest-SHA
+ optfeature "AUTH NTLM support" dev-perl/Authen-NTLM
+ optfeature "AUTH DIGEST-MD5 support" dev-perl/Authen-SASL
+ optfeature "MX routing support" dev-perl/Net-DNS
+ optfeature "TLS support" dev-perl/Net-SSLeay
+ optfeature "High Resolution Timing support" virtual/perl-Time-HiRes
+}