summaryrefslogtreecommitdiff
path: root/net-mail/vacation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /net-mail/vacation
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'net-mail/vacation')
-rw-r--r--net-mail/vacation/Manifest2
-rw-r--r--net-mail/vacation/vacation-1.2.7.0.ebuild32
2 files changed, 15 insertions, 19 deletions
diff --git a/net-mail/vacation/Manifest b/net-mail/vacation/Manifest
index 63af6264d25f..f172ecb71d7c 100644
--- a/net-mail/vacation/Manifest
+++ b/net-mail/vacation/Manifest
@@ -1,3 +1,3 @@
DIST vacation-1.2.7.0.tar.gz 63849 BLAKE2B d2f2737677b0fe075041bac0a32b6f5f57d072040448b61416e7fee98e7d4184bbd22e25734ed5e4deeabb0d0c32953821d383c9d16cf79b325fa7f261956333 SHA512 50473777fa5d36c1b7ab438e1072a56298f8155c7aaa8f8d8daaa1dee5f85f54a7b17903c416e67dbac734368b1cdbbc599cd9aa58132b0ecb145ae8e058e97d
-EBUILD vacation-1.2.7.0.ebuild 853 BLAKE2B c6cafd7768e1cd844d9b4c7b97a03914278d6dc200a667a48647866fc87a96b793f01c146f2a776d221d5fad92a97afde61b9c1de6e3b5e3b14af181201b6f7b SHA512 18db109406292bcaecd4f677c5761d3eea36d4398b445850b88a12cb8de987b9f9518c4db0354ff46bf82b819b7aecc9d9bd391bb895b68088f27fed2bf61b7a
+EBUILD vacation-1.2.7.0.ebuild 683 BLAKE2B f82fdc4a3a3f25949694b8ad41b30d0a5a2abdd0ef6fc5bc453b363b395d39f890a8430cd503e365f0753fdafe29bbcf4d0807d3bc9c441356cefc9407e338f0 SHA512 33690a825953a6f9d6a3328ba7e2ec3ce0e27250cc8d41a5574aad96eec5a028c823b016af0bc267298f5b493e3c91755d9230747fa1ff9b0cae00d5570278a1
MISC metadata.xml 250 BLAKE2B d0daf7c0246f1ceb0d3323e9c0a24dcd85198cbd2a1cee896efc79add248a7ecd4d84a47d82d4681d44adb831285c82aedab58d1ad4aff0337deaf39c8df5de3 SHA512 eb1ce5a9aee93887dfd2e2492529a60e4b95b9dbf2dd1bb49cfa4cc00cc1388fe8c2d7f0c51a9155df1b0f7f04035aca2e3320ead405517e3da2d34914515c1e
diff --git a/net-mail/vacation/vacation-1.2.7.0.ebuild b/net-mail/vacation/vacation-1.2.7.0.ebuild
index a564b6285344..89462f5392f1 100644
--- a/net-mail/vacation/vacation-1.2.7.0.ebuild
+++ b/net-mail/vacation/vacation-1.2.7.0.ebuild
@@ -1,38 +1,34 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="automatic mail answering program"
HOMEPAGE="http://vacation.sourceforge.net/"
SRC_URI="mirror://sourceforge/vacation/${P}.tar.gz"
+
LICENSE="GPL-2"
KEYWORDS="alpha amd64 x86"
SLOT="0"
-IUSE=""
-RDEPEND="virtual/mta
- sys-libs/gdbm"
-DEPEND="${RDEPEND}
- !mail-mta/sendmail"
+RDEPEND="!mail-mta/sendmail
+ sys-libs/gdbm
+ virtual/mta"
+DEPEND="${RDEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ default
- sed -i -e "s:install -s -m:install -m:" Makefile
- sed -i -e "s:-Xlinker:${LDFLAGS} -Xlinker:" Makefile
+ sed -i -e "s:install -s -m:install -m:" \
+ -e "s:-Xlinker:${LDFLAGS} -Xlinker:" Makefile || die
}
src_compile () {
- emake CC=$(tc-getCC) ARCH=$(tc-arch-kernel) CFLAGS="${CFLAGS} -DMAIN" || die "emake failed."
+ emake CFLAGS="${CFLAGS} -DMAIN"
}
src_install () {
- dodir /usr/bin
- dodir /usr/share/man/man1
- emake BINDIR="${D}/usr/bin" MANDIR="${D}usr/share/man/man" install || die \
- "make install failed"
+ emake BINDIR="${ED}/usr/bin" MANDIR="${ED}/usr/share/man/man" install
}