summaryrefslogtreecommitdiff
path: root/net-mail/rss2email/rss2email-3.13.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /net-mail/rss2email/rss2email-3.13.1.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'net-mail/rss2email/rss2email-3.13.1.ebuild')
-rw-r--r--net-mail/rss2email/rss2email-3.13.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-mail/rss2email/rss2email-3.13.1.ebuild b/net-mail/rss2email/rss2email-3.13.1.ebuild
new file mode 100644
index 000000000000..4efe89638d75
--- /dev/null
+++ b/net-mail/rss2email/rss2email-3.13.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Tests are broken for Python >=3.9
+# (see upstream issue https://github.com/rss2email/rss2email/issues/178)
+PYTHON_COMPAT=( python3_{7..8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python script that converts RSS/Atom newsfeeds to email"
+HOMEPAGE="https://github.com/rss2email/rss2email"
+SRC_URI="https://github.com/rss2email/rss2email/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/feedparser-6[${PYTHON_USEDEP}]
+ >=dev-python/html2text-2020.1.16[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+src_install() {
+ distutils-r1_src_install
+ doman r2e.1
+}
+
+python_test() {
+ cd test/ || die # or the tests won't find their data
+ distutils-r1_python_test
+}