summaryrefslogtreecommitdiff
path: root/net-mail/qmrtg/qmrtg-2.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /net-mail/qmrtg/qmrtg-2.1-r2.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'net-mail/qmrtg/qmrtg-2.1-r2.ebuild')
-rw-r--r--net-mail/qmrtg/qmrtg-2.1-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-mail/qmrtg/qmrtg-2.1-r2.ebuild b/net-mail/qmrtg/qmrtg-2.1-r2.ebuild
new file mode 100644
index 000000000000..76d25064d2e2
--- /dev/null
+++ b/net-mail/qmrtg/qmrtg-2.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A tool to analyze qmail activity with the goal to graph everything through MRTG"
+HOMEPAGE="http://dev.publicshout.org/qmrtg"
+SRC_URI="http://dev.publicshout.org/qmrtg/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+PATCHES=(
+ "${FILESDIR}"/mrtg.cfg.patch
+ "${FILESDIR}"/qmrtg.conf.sample.patch
+ "${FILESDIR}"/${P}-TAI_STR_LEN.patch
+)
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's|^CFLAGS =|CFLAGS ?=|g' \
+ analyzers/Makefile.in filters/Makefile.in || die
+}
+
+DOCS=( INSTALL.txt )
+
+src_install () {
+ default
+
+ keepdir /var/lib/qmrtg
+
+ if use doc ; then
+ docinto txt
+ dodoc doc/*.txt
+ docinto html
+ dodoc -r html/*
+ fi
+
+ insinto /usr/share/qmrtg2
+ doins examples/*
+}