summaryrefslogtreecommitdiff
path: root/net-mail/qmrtg/qmrtg-2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-mail/qmrtg/qmrtg-2.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-mail/qmrtg/qmrtg-2.1-r1.ebuild')
-rw-r--r--net-mail/qmrtg/qmrtg-2.1-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-mail/qmrtg/qmrtg-2.1-r1.ebuild b/net-mail/qmrtg/qmrtg-2.1-r1.ebuild
new file mode 100644
index 000000000000..dad4124cce50
--- /dev/null
+++ b/net-mail/qmrtg/qmrtg-2.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="A tool to analyze qmail activity with the goal to graph everything through MRTG"
+HOMEPAGE="http://dev.publicshout.org/qmrtg"
+SRC_URI="${HOMEPAGE}/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="net-analyzer/mrtg"
+
+src_prepare() {
+ sed -i \
+ -e 's|^CFLAGS =|CFLAGS ?=|g' \
+ analyzers/Makefile.in filters/Makefile.in || die
+
+ epatch "${FILESDIR}"/mrtg.cfg.patch
+ epatch "${FILESDIR}"/qmrtg.conf.sample.patch
+ epatch "${FILESDIR}"/${P}-TAI_STR_LEN.patch
+}
+
+DOCS=( INSTALL.txt )
+
+src_install () {
+ default
+ keepdir /var/lib/qmrtg
+ if use doc ; then
+ docinto txt
+ dodoc doc/*.txt
+ docinto html
+ dohtml -r html/*
+ fi
+
+ insinto /usr/share/qmrtg2
+ doins examples/*
+
+}
+
+pkg_postinst () {
+ elog
+ elog "You need to configure manually qmrtg in order to run it."
+ elog "The configuration templates in /usr/share/qmrtg2/ and"
+ elog "the INSTALL file in /usr/share/doc/qmrtg-2.1/"
+ elog "will be useful."
+ elog
+}