summaryrefslogtreecommitdiff
path: root/net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild')
-rw-r--r--net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild39
1 files changed, 20 insertions, 19 deletions
diff --git a/net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild b/net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild
index efdab855bc16..5e085af316f0 100644
--- a/net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild
+++ b/net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils fixheadtails toolchain-funcs
+inherit fixheadtails toolchain-funcs
DESCRIPTION="collection of tools to help you analyze qmail's activity record"
SRC_URI="http://cr.yp.to/software/${P}.tar.gz"
@@ -16,20 +16,22 @@ IUSE=""
DEPEND="sys-apps/groff"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PV}-errno.patch
+src_prepare() {
+ eapply_user
+ eapply "${FILESDIR}"/${PV}-errno.patch
ht_fix_file auto_home.c.do default.do Makefile
}
-src_compile() {
- echo "/var/qmail" > conf-home
- echo "$(tc-getCC) ${CFLAGS}" > conf-cc
- echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+src_configure() {
+ echo "/var/qmail" > conf-home || die
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc || die
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld || die
+}
- emake || die
- $(tc-getCC) ${CFLAGS} "${FILESDIR}"/tai64nfrac.c -o tai64nfrac || die
+src_compile() {
+ default
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} \
+ "${FILESDIR}"/tai64nfrac.c -o tai64nfrac || die
}
src_test() { :; }
@@ -38,11 +40,10 @@ src_install() {
doman matchup.1 xqp.1 xsender.1 xrecipient.1 columnt.1
dodoc MATCHUP ACCOUNTING BLURB
- insopts -o root -g qmail -m 755
- insinto /var/qmail/bin
- into /var/qmail
- dobin columnt ddist deferrals failures matchup recipients rhosts
- dobin rxdelay senders successes suids xqp xrecipient xsender
- dobin zddist zdeferrals zfailures zoverall zrecipients zrhosts
- dobin zrxdelay zsenders zsendmail zsuccesses zsuids tai64nfrac
+ exeopts -o root -g qmail -m 755
+ exeinto /var/qmail/bin
+ doexe columnt ddist deferrals failures matchup recipients rhosts
+ doexe rxdelay senders successes suids xqp xrecipient xsender
+ doexe zddist zdeferrals zfailures zoverall zrecipients zrhosts
+ doexe zrxdelay zsenders zsendmail zsuccesses zsuids tai64nfrac
}