summaryrefslogtreecommitdiff
path: root/net-mail/public-inbox/public-inbox-1.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-24 08:47:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-24 08:47:16 +0100
commit7405d8a728a9553d7b8eccb67737c5193c9f13ba (patch)
treeb724a0d3f660dce5eb1a6a7aedb3e83f983c4dfd /net-mail/public-inbox/public-inbox-1.9.0.ebuild
parent2d51a70c0ec989cfc28d2d9a140206a601378c58 (diff)
gentoo auto-resync : 24:08:2022 - 08:47:15
Diffstat (limited to 'net-mail/public-inbox/public-inbox-1.9.0.ebuild')
-rw-r--r--net-mail/public-inbox/public-inbox-1.9.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-mail/public-inbox/public-inbox-1.9.0.ebuild b/net-mail/public-inbox/public-inbox-1.9.0.ebuild
new file mode 100644
index 000000000000..07d953b9e7ca
--- /dev/null
+++ b/net-mail/public-inbox/public-inbox-1.9.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="An archives-first approach to mailing lists"
+HOMEPAGE="https://public-inbox.org"
+SRC_URI="https://public-inbox.org/public-inbox.git/snapshot/${P}.tar.gz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# in order of mention in INSTALL.html, going more for feature completeness
+# than for minimal footprint
+RDEPEND="
+ dev-perl/BSD-Resource
+ dev-perl/DBD-SQLite
+ dev-perl/Email-Address-XS
+ dev-perl/Inline-C
+ dev-perl/Linux-Inotify2
+ dev-perl/Mail-IMAPClient
+ dev-perl/Net-Server
+ dev-perl/Parse-RecDescent
+ dev-perl/Plack
+ dev-perl/Search-Xapian
+ dev-perl/TimeDate
+ dev-perl/URI
+ dev-vcs/git
+ net-misc/curl
+ virtual/mta
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"