summaryrefslogtreecommitdiff
path: root/net-mail/notmuch/notmuch-0.29.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /net-mail/notmuch/notmuch-0.29.2.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'net-mail/notmuch/notmuch-0.29.2.ebuild')
-rw-r--r--net-mail/notmuch/notmuch-0.29.2.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/net-mail/notmuch/notmuch-0.29.2.ebuild b/net-mail/notmuch/notmuch-0.29.2.ebuild
index e845830282d8..b10795cfe09a 100644
--- a/net-mail/notmuch/notmuch-0.29.2.ebuild
+++ b/net-mail/notmuch/notmuch-0.29.2.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+PYTHON_COMPAT=( python{2_7,3_6,3_7} )
inherit bash-completion-r1 elisp-common eutils flag-o-matic pax-utils \
distutils-r1 toolchain-funcs
DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
HOMEPAGE="https://notmuchmail.org/"
-SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.xz
- test? ( ${HOMEPAGE%/}/releases/test-databases/database-v1.tar.xz )"
+SRC_URI="https://notmuchmail.org/releases/${P}.tar.xz
+ test? ( https://notmuchmail.org/releases/test-databases/database-v1.tar.xz )"
LICENSE="GPL-3"
# Sub-slot corresponds to major wersion of libnotmuch.so.X.Y. Bump of Y is
@@ -38,7 +38,7 @@ CDEPEND="
>=sys-libs/zlib-1.2.5.2
sys-libs/talloc
crypt? ( dev-libs/gmime:3.0[crypt] )
- emacs? ( >=virtual/emacs-23 )
+ emacs? ( >=app-editors/emacs-24.1:* )
python? ( ${PYTHON_DEPS} )
"
DEPEND="${CDEPEND}
@@ -49,7 +49,7 @@ DEPEND="${CDEPEND}
)
test? (
app-misc/dtach
- || ( >=app-editors/emacs-23[libxml2] >=app-editors/emacs-vcs-23[libxml2] )
+ >=app-editors/emacs-24.1:*[libxml2]
sys-devel/gdb
crypt? ( app-crypt/gnupg dev-libs/openssl )
)
@@ -72,6 +72,7 @@ RDEPEND="${CDEPEND}
"
DOCS=( AUTHORS NEWS README )
+NEED_EMACS="24.1"
SITEFILE="50${PN}-gentoo.el"
MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
PATCHES=(
@@ -103,9 +104,7 @@ pkg_pretend() {
}
pkg_setup() {
- if use emacs; then
- elisp-need-emacs 23 || die "Emacs version too low"
- fi
+ use emacs && elisp-check-emacs-version
}
src_unpack() {