summaryrefslogtreecommitdiff
path: root/net-mail/mess822/mess822-0.58-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-mail/mess822/mess822-0.58-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-mail/mess822/mess822-0.58-r2.ebuild')
-rw-r--r--net-mail/mess822/mess822-0.58-r2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-mail/mess822/mess822-0.58-r2.ebuild b/net-mail/mess822/mess822-0.58-r2.ebuild
new file mode 100644
index 000000000000..95c6b44751e5
--- /dev/null
+++ b/net-mail/mess822/mess822-0.58-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit multilib toolchain-funcs eutils
+
+DESCRIPTION="Collection of utilities for parsing Internet mail messages"
+SRC_URI="http://cr.yp.to/software/${P}.tar.gz"
+HOMEPAGE="http://cr.yp.to/mess822.html"
+
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+LICENSE="public-domain"
+
+RDEPEND=">=sys-apps/sed-4"
+DEPEND="${RDEPEND}"
+RESTRICT="test"
+
+src_prepare() {
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ echo "/usr" > conf-home
+
+ # fix errno.h problem; bug #26165
+ sed -i 's/^extern int errno;/#include <errno.h>/' error.h
+
+ epatch "${FILESDIR}"/${P}-implicit.patch
+}
+
+src_install() {
+ dodir /etc
+ dodir /usr/share
+
+ # Now that the commands are compiled, update the conf-home file to point
+ # to the installation image directory.
+ echo "${D}/usr/" > conf-home
+ sed -i -e "s:\"/etc\":\"${D}/etc\":" hier.c || die "sed hier.c failed"
+
+ emake setup
+
+ # Move the man pages into /usr/share/man
+ mv "${D}/usr/man" "${D}/usr/share/"
+
+ dodir /usr/$(get_libdir)
+ mv "${D}/usr/lib/${PN}.a" "${D}/usr/$(get_libdir)/${PN}.a"
+ rmdir "${D}/usr/lib"
+ dodoc BLURB CHANGES INSTALL README THANKS TODO VERSION
+}