summaryrefslogtreecommitdiff
path: root/net-mail/mboxgrep/mboxgrep-0.7.9-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /net-mail/mboxgrep/mboxgrep-0.7.9-r2.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'net-mail/mboxgrep/mboxgrep-0.7.9-r2.ebuild')
-rw-r--r--net-mail/mboxgrep/mboxgrep-0.7.9-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-mail/mboxgrep/mboxgrep-0.7.9-r2.ebuild b/net-mail/mboxgrep/mboxgrep-0.7.9-r2.ebuild
new file mode 100644
index 000000000000..5e42763bd887
--- /dev/null
+++ b/net-mail/mboxgrep/mboxgrep-0.7.9-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Grep for mbox files"
+SRC_URI="mirror://sourceforge/mboxgrep/${P}.tar.gz"
+HOMEPAGE="https://datatipp.se/mboxgrep/"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dmalloc"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-libs/libpcre
+ sys-libs/zlib
+ dmalloc? ( dev-libs/dmalloc )
+"
+DEPEND="
+ ${RDEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-_DEFAULT_SOURCE.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-ldflags.patch
+)
+
+src_configure() {
+ econf \
+ $(use_with dmalloc no yes)
+}
+
+src_install() {
+ emake \
+ prefix="${D}"/usr \
+ mandir="${D}"/usr/share/man \
+ infodir="${D}"/usr/share/info \
+ install
+ dodoc ChangeLog NEWS TODO README
+}