summaryrefslogtreecommitdiff
path: root/net-mail/mailutils/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /net-mail/mailutils/files
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'net-mail/mailutils/files')
-rw-r--r--net-mail/mailutils/files/mailutils-2.99.98-readline-6.3.patch39
-rw-r--r--net-mail/mailutils/files/mailutils-3.6-python3.patch59
-rw-r--r--net-mail/mailutils/files/mailutils-3.6-underlinking.patch11
3 files changed, 70 insertions, 39 deletions
diff --git a/net-mail/mailutils/files/mailutils-2.99.98-readline-6.3.patch b/net-mail/mailutils/files/mailutils-2.99.98-readline-6.3.patch
deleted file mode 100644
index de9a487aaaf3..000000000000
--- a/net-mail/mailutils/files/mailutils-2.99.98-readline-6.3.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-https://bugs.gentoo.org/503954
-
-fix build w/readline-6.3
-
-patch by Martin von Gagern
-
---- mailutils-2.99.98/mu/shell.c
-+++ mailutils-2.99.98/mu/shell.c
-@@ -336,7 +336,7 @@ mutool_initialize_readline (const char *
- {
- /* Allow conditional parsing of the ~/.inputrc file. */
- rl_readline_name = (char *) name;
-- rl_attempted_completion_function = (CPPFunction *) shell_completion;
-+ rl_attempted_completion_function = shell_completion;
- rl_getc_function = _shell_getc;
- read_history (get_history_file_name ());
- }
---- mailutils-2.99.98/mail/mailline.c
-+++ mailutils-2.99.98/mail/mailline.c
-@@ -93,7 +93,7 @@ ml_readline_init ()
-
- #ifdef WITH_READLINE
- rl_readline_name = "mail";
-- rl_attempted_completion_function = (CPPFunction*)ml_command_completion;
-+ rl_attempted_completion_function = ml_command_completion;
- rl_getc_function = ml_getc;
- #endif
- #ifdef HAVE_SIGACTION
---- mailutils-2.99.98/examples/nntpclient.c
-+++ mailutils-2.99.98/examples/nntpclient.c
-@@ -163,7 +163,7 @@ initialize_readline ()
- rl_readline_name = (char *) "nntp";
-
- /* Tell the completer that we want a crack first. */
-- rl_attempted_completion_function = (CPPFunction *) nntp_completion;
-+ rl_attempted_completion_function = nntp_completion;
- }
-
- /* Attempt to complete on the contents of TEXT. START and END bound the
diff --git a/net-mail/mailutils/files/mailutils-3.6-python3.patch b/net-mail/mailutils/files/mailutils-3.6-python3.patch
new file mode 100644
index 000000000000..cad46d006a2a
--- /dev/null
+++ b/net-mail/mailutils/files/mailutils-3.6-python3.patch
@@ -0,0 +1,59 @@
+From 4e66a6a9e5f5696d60f7df875175f2e0ad8f7376 Mon Sep 17 00:00:00 2001
+From: Sergey Poznyakoff <gray@gnu.org>
+Date: Sun, 24 Feb 2019 22:56:21 +0200
+Subject: Bugfix
+
+* python/3/libmu_py/mailcap.c: Fix leftover uses of PyString_FromString
+and PyInt_FromLong.
+---
+ python/3/libmu_py/mailcap.c | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/python/3/libmu_py/mailcap.c b/python/3/libmu_py/mailcap.c
+index 6db1770..fdb5b71 100644
+--- a/python/3/libmu_py/mailcap.c
++++ b/python/3/libmu_py/mailcap.c
+@@ -91,11 +91,11 @@ api_mailcap_create (PyObject *self, PyObject *args)
+
+ status = mu_mailcap_create (&py_mc->mc);
+ if (status)
+- return _ro (PyInt_FromLong (status));
++ return _ro (PyLong_FromLong (status));
+ status = mu_mailcap_parse (py_mc->mc, py_stm->stm, NULL);
+ if (status == MU_ERR_PARSE)
+ status = 0; /* FIXME */
+- return _ro (PyInt_FromLong (status));
++ return _ro (PyLong_FromLong (status));
+ }
+
+ static PyObject *
+@@ -183,7 +183,7 @@ api_mailcap_entry_get_field (PyObject *self, PyObject *args)
+ status = mu_mailcap_entry_sget_field (py_entry->entry, name, &value);
+ return status_object (status,
+ status == 0
+- ? (value ? PyString_FromString (value)
++ ? (value ? PyUnicode_FromString (value)
+ : PyBool_FromLong (1))
+ : PyBool_FromLong (0));
+ }
+@@ -199,7 +199,7 @@ api_mailcap_entry_get_typefield (PyObject *self, PyObject *args)
+ return NULL;
+
+ status = mu_mailcap_entry_sget_type (py_entry->entry, &value);
+- return status_object (status, PyString_FromString (status == 0 ? value : ""));
++ return status_object (status, PyUnicode_FromString (status == 0 ? value : ""));
+ }
+
+ static PyObject *
+@@ -213,7 +213,7 @@ api_mailcap_entry_get_viewcommand (PyObject *self, PyObject *args)
+ return NULL;
+
+ status = mu_mailcap_entry_sget_command (py_entry->entry, &value);
+- return status_object (status, PyString_FromString (status == 0 ? value : ""));
++ return status_object (status, PyUnicode_FromString (status == 0 ? value : ""));
+ }
+
+ static PyMethodDef methods[] = {
+--
+cgit v1.0-41-gc330
+
diff --git a/net-mail/mailutils/files/mailutils-3.6-underlinking.patch b/net-mail/mailutils/files/mailutils-3.6-underlinking.patch
new file mode 100644
index 000000000000..512a05f3a313
--- /dev/null
+++ b/net-mail/mailutils/files/mailutils-3.6-underlinking.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac 2019-02-26 17:11:29.398115222 +0300
++++ b/configure.ac 2019-02-26 17:14:13.733899654 +0300
+@@ -985,7 +985,7 @@
+ AC_CHECK_LIB(ldap, ldap_bind,[
+ status_ldap=yes
+ AC_DEFINE(WITH_LDAP, 1, [Define to 1 if you want to use -lldap])
+- MU_AUTHLIBS="$MU_AUTHLIBS -lldap"],
++ MU_AUTHLIBS="$MU_AUTHLIBS -lldap -llber"],
+ [status_ldap=no])
+ fi
+