summaryrefslogtreecommitdiff
path: root/net-mail/mailbox-count/mailbox-count-0.0.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-26 23:59:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-26 23:59:37 +0100
commit3e42d1577189af123b773dc0f11e5419035308c8 (patch)
tree95d77507c924544b12363e6da6aa741c444f3e8a /net-mail/mailbox-count/mailbox-count-0.0.8.ebuild
parent6243676c91946098c06d42bc87b5eb99aac40bf0 (diff)
gentoo auto-resync : 26:04:2024 - 23:59:36
Diffstat (limited to 'net-mail/mailbox-count/mailbox-count-0.0.8.ebuild')
-rw-r--r--net-mail/mailbox-count/mailbox-count-0.0.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-mail/mailbox-count/mailbox-count-0.0.8.ebuild b/net-mail/mailbox-count/mailbox-count-0.0.8.ebuild
new file mode 100644
index 000000000000..c2af7578eb1c
--- /dev/null
+++ b/net-mail/mailbox-count/mailbox-count-0.0.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Count mailboxes in a SQL database"
+HOMEPAGE="https://michael.orlitzky.com/code/mailbox-count.xhtml"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/cmdargs-0.10
+ >=dev-haskell/configurator-0.2
+ >=dev-haskell/hdbc-2.4
+ >=dev-haskell/hdbc-postgresql-2.3
+ >=dev-haskell/hdbc-sqlite3-2.3
+ >=dev-haskell/missingh-1.2
+ >=dev-haskell/tasty-0.8
+ >=dev-haskell/tasty-hunit-0.8
+ >=dev-lang/ghc-9.0
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0
+ test? ( >=dev-haskell/doctest-0.9
+ >=dev-haskell/filemanip-0.3.6 )"
+
+src_install() {
+ haskell-cabal_src_install
+ dodoc "${S}/doc/${PN}rc.example"
+ doman "${S}/doc/man1/${PN}.1"
+}