summaryrefslogtreecommitdiff
path: root/net-mail/isync/isync-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-13 21:03:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-13 21:03:07 +0100
commit8fbd420dce8836e6503b162092e07b6a77a89f1d (patch)
tree071c621ef44d7c1b24a430ac7671d68963b5a4cf /net-mail/isync/isync-9999.ebuild
parent12d78242dec4f785d0a0bfb1c00eee2d8996c53b (diff)
gentoo resync : 13.10.2017
Diffstat (limited to 'net-mail/isync/isync-9999.ebuild')
-rw-r--r--net-mail/isync/isync-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-mail/isync/isync-9999.ebuild b/net-mail/isync/isync-9999.ebuild
new file mode 100644
index 000000000000..a91ca12fb5bf
--- /dev/null
+++ b/net-mail/isync/isync-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="MailDir mailbox synchronizer"
+HOMEPAGE="http://isync.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/${PN}/${PN}"
+ inherit git-r3 autotools
+else
+ SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~x86"
+fi
+
+IUSE="libressl sasl ssl zlib"
+
+RDEPEND="
+ >=sys-libs/db-4.2:=
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-0.9.6:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ zlib? ( sys-libs/zlib:0= )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare () {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure () {
+ econf \
+ $(use_with ssl) \
+ $(use_with sasl) \
+ $(use_with zlib)
+}