summaryrefslogtreecommitdiff
path: root/net-mail/grepmail/grepmail-5.3111.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /net-mail/grepmail/grepmail-5.3111.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'net-mail/grepmail/grepmail-5.3111.ebuild')
-rw-r--r--net-mail/grepmail/grepmail-5.3111.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-mail/grepmail/grepmail-5.3111.ebuild b/net-mail/grepmail/grepmail-5.3111.ebuild
new file mode 100644
index 000000000000..ef49558b1a95
--- /dev/null
+++ b/net-mail/grepmail/grepmail-5.3111.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="Search normal or compressed mailbox using a regular expression or dates"
+HOMEPAGE="https://github.com/coppit/grepmail"
+SRC_URI="mirror://cpan/authors/id/D/DC/DCOPPIT/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/Date-Manip
+ dev-perl/File-HomeDir
+ dev-perl/Inline
+ >=dev-perl/Mail-Mbox-MessageParser-1.40.01
+ dev-perl/TimeDate
+ virtual/perl-Digest-MD5
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Compile
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )
+"