summaryrefslogtreecommitdiff
path: root/net-mail/gnubiff/gnubiff-2.2.17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-mail/gnubiff/gnubiff-2.2.17.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-mail/gnubiff/gnubiff-2.2.17.ebuild')
-rw-r--r--net-mail/gnubiff/gnubiff-2.2.17.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-mail/gnubiff/gnubiff-2.2.17.ebuild b/net-mail/gnubiff/gnubiff-2.2.17.ebuild
new file mode 100644
index 000000000000..a370cd6f9114
--- /dev/null
+++ b/net-mail/gnubiff/gnubiff-2.2.17.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="A mail notification program"
+HOMEPAGE="http://gnubiff.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug fam nls password"
+
+RDEPEND="
+ >=x11-libs/gtk+-3:3
+ >=gnome-base/libglade-2.3
+ dev-libs/popt
+ password? ( dev-libs/openssl:* )
+ fam? ( virtual/fam )
+ x11-proto/xproto
+ x11-libs/libX11
+ x11-libs/pango
+ x11-libs/gdk-pixbuf
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS TODO"
+
+src_prepare() {
+ eapply -p0 "${FILESDIR}/${PN}-2.2.15-fix-nls.patch"
+ eapply -p1 "${FILESDIR}/${PN}-2.2.15-gold.patch"
+ eapply -p0 "${FILESDIR}/${PN}-2.2.15-underlink.patch"
+ eautoreconf
+ eapply_user
+}
+
+src_configure() {
+ # note: --disable-gnome is to avoid deprecated gnome-panel-2.x
+ econf \
+ --disable-gnome \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable fam) \
+ $(use_with password) \
+ $(use_with password password-string ${RANDOM}${RANDOM}${RANDOM}${RANDOM})
+}