summaryrefslogtreecommitdiff
path: root/net-mail/getmail/getmail-6.18.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-22 11:16:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-22 11:16:57 +0100
commit92a9a3adda432ad2b7af58e08f5493ed6dc81196 (patch)
tree875f2d54382fdb68add8e3a92e44e49447be4a4b /net-mail/getmail/getmail-6.18.13.ebuild
parent67ff4e881df5f5a1482662d6aba4680f82d12197 (diff)
gentoo auto-resync : 22:09:2023 - 11:16:57
Diffstat (limited to 'net-mail/getmail/getmail-6.18.13.ebuild')
-rw-r--r--net-mail/getmail/getmail-6.18.13.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-mail/getmail/getmail-6.18.13.ebuild b/net-mail/getmail/getmail-6.18.13.ebuild
new file mode 100644
index 000000000000..92fafc18bdfc
--- /dev/null
+++ b/net-mail/getmail/getmail-6.18.13.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_REQ_USE="ssl"
+inherit distutils-r1
+
+DESCRIPTION="A mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="https://www.getmail6.org/ https://github.com/getmail6/getmail6"
+SRC_URI="https://github.com/getmail6/getmail6/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/getmail6-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_prepare_all() {
+ # Use gentoo version number (including revision) for doc dir and remove COPYING file
+ sed -i -e "s,'getmail-%s' % __version__,'${PF}'," \
+ -e "/docs\/COPYING/d" "${S}"/setup.py || die
+
+ distutils-r1_python_prepare_all
+}