summaryrefslogtreecommitdiff
path: root/net-mail/ezmlm-idx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /net-mail/ezmlm-idx
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'net-mail/ezmlm-idx')
-rw-r--r--net-mail/ezmlm-idx/Manifest2
-rw-r--r--net-mail/ezmlm-idx/ezmlm-idx-7.2.2.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/net-mail/ezmlm-idx/Manifest b/net-mail/ezmlm-idx/Manifest
index b5612312e069..810e18c7f552 100644
--- a/net-mail/ezmlm-idx/Manifest
+++ b/net-mail/ezmlm-idx/Manifest
@@ -1,3 +1,5 @@
DIST ezmlm-idx-7.0.0.tar.gz 689019 BLAKE2B 22c66a4a2fcc6c0c754061ff0d93bde8fd192266112da0516e936278610288dc11d44d1959cd135a90eacb4befa43d62f53b3bedb94e994afc13aed986834bce SHA512 c0fc35aef4a72aefa4cdaee4c1933cc00aab82ee81ad7577793952fbf57106c06e4a5844a2bbf3919ad2985d2062ba1edf8831e6aa66d7e762210e7e147210ef
+DIST ezmlm-idx-7.2.2.tar.gz 742451 BLAKE2B fd40b1216d34eba253ef00a53366c8a5f2d19edd9ef20ddea3047a6837263589ac8fc4911820836b49bf4c95b99a1c99d3d2808bc90dd8eb58bc262e6acc74d7 SHA512 4fdd30d6dc254fd0353f34675ea8baa91d95860de1fb23ff5517280c75a8d87405bdd7e180e25eb8f5c0b152a35a11a939f4e7364596e83d81053b1e6019245c
EBUILD ezmlm-idx-7.0.0-r3.ebuild 1424 BLAKE2B 8ea76be3cc3ce3826ff5c1be24cd660835578acbf544d363a607ac8ab362085b973733dc38ab59d70b375373ba41343687bfe75f450338a15d4ad1f95c990235 SHA512 50fd8d98bf69dd62c1bdebe02247014fc42c3581279846c078ceb5739455c9b07f10f5a50d9e6ed9fb9ae4d9fe6cebdb41fe90ff0061058c0c832eab5f0b4361
+EBUILD ezmlm-idx-7.2.2.ebuild 1454 BLAKE2B b639ad78c566b03638b484e85926fdcc8ad60bf6be84a21a95d8ed39bab05366f5d7a389ed716b6a207fff8398ef516140672371e20fa45ddc9b47a109eccfb3 SHA512 ba40067c9268e0ebe0b93a500caf1e887d5cdc9f17620f3fe25e9a2b9a49c2ae2ce4efb70a55985c360dfece4b9a4bf4cdfadedcc7fcd432804ad91812db7faa
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/net-mail/ezmlm-idx/ezmlm-idx-7.2.2.ebuild b/net-mail/ezmlm-idx/ezmlm-idx-7.2.2.ebuild
new file mode 100644
index 000000000000..6d5b5f6fa41a
--- /dev/null
+++ b/net-mail/ezmlm-idx/ezmlm-idx-7.2.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmail toolchain-funcs
+
+DESCRIPTION="Simple yet powerful mailing list manager for qmail"
+HOMEPAGE="https://untroubled.org/ezmlm"
+SRC_URI="https://untroubled.org/ezmlm/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="mysql postgres sqlite"
+
+DEPEND="mysql? ( dev-db/mysql-connector-c:0= )
+ postgres? ( dev-db/postgresql:= )
+ sqlite? ( dev-db/sqlite:3 )"
+RDEPEND="${DEPEND}
+ virtual/qmail"
+REQUIRED_USE="?? ( mysql postgres sqlite )"
+
+src_prepare() {
+ default
+ echo /usr/bin > conf-bin || die
+ echo /usr/$(get_libdir)/ezmlm > conf-lib || die
+ echo /etc/ezmlm > conf-etc || die
+ echo /usr/share/man > conf-man || die
+ echo ${QMAIL_HOME} > conf-qmail || die
+
+ echo $(tc-getCC) ${CFLAGS} -I/usr/include/{my,postgre}sql > conf-cc || die
+ echo $(tc-getCC) ${LDFLAGS} -Wl,-E > conf-ld || die
+
+ # fix DESTDIR and skip cat man-pages
+ sed -e "s:\(/installer\) \(\"\`head\):\1 ${D}\2:" \
+ -e "s:\(./install.*\) < MAN$:grep -v \:/cat MAN | \1:" \
+ -e "s:\(\"\`head -n 1 conf-etc\`\"/default\):${D}\1:" \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake it man installer
+
+ if use mysql; then
+ emake mysql
+ elif use postgres; then
+ emake pgsql
+ elif use sqlite; then
+ emake sqlite3
+ fi
+}
+
+src_install() {
+ dodir /usr/bin /usr/$(get_libdir)/ezmlm /etc/ezmlm /usr/share/man
+ default
+}