summaryrefslogtreecommitdiff
path: root/net-mail/checkpassword/checkpassword-0.90-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /net-mail/checkpassword/checkpassword-0.90-r4.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'net-mail/checkpassword/checkpassword-0.90-r4.ebuild')
-rw-r--r--net-mail/checkpassword/checkpassword-0.90-r4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-mail/checkpassword/checkpassword-0.90-r4.ebuild b/net-mail/checkpassword/checkpassword-0.90-r4.ebuild
new file mode 100644
index 000000000000..1680029cd0a6
--- /dev/null
+++ b/net-mail/checkpassword/checkpassword-0.90-r4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit fixheadtails toolchain-funcs
+
+DESCRIPTION="A uniform password checking interface for root applications"
+HOMEPAGE="https://cr.yp.to/checkpwd.html"
+SRC_URI="https://cr.yp.to/checkpwd/${P}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static"
+RESTRICT="mirror bindist"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-errno.patch
+ "${FILESDIR}"/${P}-exit.patch
+ "${FILESDIR}"/${P}-headers.patch
+)
+
+src_prepare() {
+ default
+
+ ht_fix_file Makefile print-cc.sh
+
+ use static && append-ldflags -static
+
+ echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS}" > ./conf-cc || die 'Patching conf-cc failed.'
+ echo "$(tc-getCC) ${LDFLAGS}" > ./conf-ld || die 'Patching conf-ld failed.'
+}
+
+src_install() {
+ dobin checkpassword
+ einstalldocs
+}