summaryrefslogtreecommitdiff
path: root/net-mail/b4/b4-0.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /net-mail/b4/b4-0.8.0.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'net-mail/b4/b4-0.8.0.ebuild')
-rw-r--r--net-mail/b4/b4-0.8.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-mail/b4/b4-0.8.0.ebuild b/net-mail/b4/b4-0.8.0.ebuild
new file mode 100644
index 000000000000..12883cde5aa6
--- /dev/null
+++ b/net-mail/b4/b4-0.8.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utility for fetching patchsets from public-inbox"
+HOMEPAGE="https://pypi.org/project/b4/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/dkimpy[${PYTHON_USEDEP}]
+ dev-python/patatt[${PYTHON_USEDEP}]
+"