summaryrefslogtreecommitdiff
path: root/net-libs/zeromq/zeromq-4.3.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /net-libs/zeromq/zeromq-4.3.4-r1.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'net-libs/zeromq/zeromq-4.3.4-r1.ebuild')
-rw-r--r--net-libs/zeromq/zeromq-4.3.4-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/zeromq/zeromq-4.3.4-r1.ebuild b/net-libs/zeromq/zeromq-4.3.4-r1.ebuild
new file mode 100644
index 000000000000..9a32f20db6b1
--- /dev/null
+++ b/net-libs/zeromq/zeromq-4.3.4-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools
+
+DESCRIPTION="A brokerless kernel"
+HOMEPAGE="https://zeromq.org/"
+SRC_URI="https://github.com/zeromq/libzmq/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/5"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="doc drafts +libbsd pgm +sodium static-libs test unwind elibc_Darwin"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !elibc_Darwin? ( unwind? ( sys-libs/libunwind ) )
+ libbsd? ( dev-libs/libbsd:= )
+ sodium? ( dev-libs/libsodium:= )"
+DEPEND="${RDEPEND}
+ !elibc_Darwin? ( sys-apps/util-linux )
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ )
+ pgm? ( virtual/pkgconfig )"
+
+src_prepare() {
+ sed \
+ -e '/libzmq_werror=/s:yes:no:g' \
+ -i configure.ac || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ --without-pgm
+ $(use_enable drafts)
+ $(use_enable libbsd)
+ $(use_enable static-libs static)
+ $(use_enable unwind libunwind)
+ $(use_with sodium libsodium)
+ $(use_with doc docs)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # Restricting to one job because multiple tests are using the same port.
+ # Upstream knows the problem and says it doesn't support parallel test
+ # execution, see ${S}/INSTALL.
+ emake -j1 check
+}
+
+src_install() {
+ default
+ find "${ED}"/usr/lib* -name '*.la' -delete || die
+}