summaryrefslogtreecommitdiff
path: root/net-libs/zeromq/zeromq-3.2.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
commit9c417bacd51da6d8b57fa9f37425161d30d4b95b (patch)
tree47c9d6e4243f39a1f48afd54c969b65b00a5c649 /net-libs/zeromq/zeromq-3.2.5.ebuild
parentd934827bf44b7cfcf6711964418148fa60877668 (diff)
gentoo resync : 28.11.2020
Diffstat (limited to 'net-libs/zeromq/zeromq-3.2.5.ebuild')
-rw-r--r--net-libs/zeromq/zeromq-3.2.5.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/net-libs/zeromq/zeromq-3.2.5.ebuild b/net-libs/zeromq/zeromq-3.2.5.ebuild
deleted file mode 100644
index 2d97ae7df61c..000000000000
--- a/net-libs/zeromq/zeromq-3.2.5.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools
-
-DESCRIPTION="ZeroMQ is a brokerless kernel"
-HOMEPAGE="http://www.zeromq.org/"
-SRC_URI="http://download.zeromq.org/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0/3"
-KEYWORDS="amd64 arm hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="pgm test static-libs elibc_glibc"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- || ( sys-devel/gcc sys-devel/gcc-apple )
- pgm? (
- virtual/pkgconfig
- >=net-libs/openpgm-5.2
- )
- elibc_glibc? ( sys-apps/util-linux )"
-RDEPEND=""
-
-src_prepare() {
- einfo "Removing bundled OpenPGM library"
- sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.in || die
- rm -r "${S}"/foreign/openpgm/libpgm* || die
- # apply effective bit of below commit to fix compilation on Darwin
- # https://github.com/zeromq/zeromq3-x/commit/400cbc208a768c4df5039f401dd2688eede6e1ca
- sed -i -e '/strndup/d' tests/test_disconnect_inproc.cpp || die
- mv configure.{in,ac} || die
- eautoreconf
-}
-
-src_configure() {
- local myconf
- use pgm && myconf="--with-system-pgm" || myconf="--without-pgm"
- econf \
- $(use_enable static-libs static) \
- ${myconf}
-}
-
-src_test() {
- emake -j1 check
-}
-
-src_install() {
- default
- doman doc/*.[1-9]
-
- # remove useless .la files
- find "${ED}" -name '*.la' -delete || die
-
- # remove useless .a (only for non static compilation)
- if ! use static-libs; then
- find "${ED}" -name '*.a' -delete || die
- fi
-}