summaryrefslogtreecommitdiff
path: root/net-libs/xrootd-ceph/xrootd-ceph-5.4.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /net-libs/xrootd-ceph/xrootd-ceph-5.4.3.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'net-libs/xrootd-ceph/xrootd-ceph-5.4.3.ebuild')
-rw-r--r--net-libs/xrootd-ceph/xrootd-ceph-5.4.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/xrootd-ceph/xrootd-ceph-5.4.3.ebuild b/net-libs/xrootd-ceph/xrootd-ceph-5.4.3.ebuild
new file mode 100644
index 000000000000..67129ba3bde5
--- /dev/null
+++ b/net-libs/xrootd-ceph/xrootd-ceph-5.4.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="xrootd OSS plug-in for interfacing with Ceph storage platform"
+HOMEPAGE="https://xrootd.slac.stanford.edu/"
+SRC_URI="https://github.com/xrootd/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="~net-libs/xrootd-${PV}
+ sys-cluster/ceph"
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-util/cppunit )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.4.0_no-werror.patch
+)
+
+# xrootd plugins are not intended to be linked with,
+# they are to be loaded at runtime by xrootd,
+# see https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrdCeph.*-$(ver_cut 1)\.so
+ /usr/lib.*/libXrdCephTests\.so"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}