summaryrefslogtreecommitdiff
path: root/net-libs/vanessa-socket/vanessa-socket-0.0.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/vanessa-socket/vanessa-socket-0.0.12.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/vanessa-socket/vanessa-socket-0.0.12.ebuild')
-rw-r--r--net-libs/vanessa-socket/vanessa-socket-0.0.12.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-libs/vanessa-socket/vanessa-socket-0.0.12.ebuild b/net-libs/vanessa-socket/vanessa-socket-0.0.12.ebuild
new file mode 100644
index 000000000000..88531f805655
--- /dev/null
+++ b/net-libs/vanessa-socket/vanessa-socket-0.0.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Simplifies TCP/IP socket operations"
+HOMEPAGE="http://horms.net/projects/vanessa/"
+SRC_URI="http://horms.net/projects/vanessa/download/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+DEPEND=">=dev-libs/vanessa-logger-0.0.6"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf || die "error configure"
+ emake || die "error compiling"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "error installing"
+ dodoc README NEWS AUTHORS TODO
+}