summaryrefslogtreecommitdiff
path: root/net-libs/toxext/toxext-0.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /net-libs/toxext/toxext-0.0.3.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'net-libs/toxext/toxext-0.0.3.ebuild')
-rw-r--r--net-libs/toxext/toxext-0.0.3.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/net-libs/toxext/toxext-0.0.3.ebuild b/net-libs/toxext/toxext-0.0.3.ebuild
index 83c395524343..4e41feba68bf 100644
--- a/net-libs/toxext/toxext-0.0.3.ebuild
+++ b/net-libs/toxext/toxext-0.0.3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Extension Library for Tox"
HOMEPAGE="https://github.com/toxext/toxext"
@@ -22,4 +22,8 @@ src_prepare() {
sed -i 's/-Werror//' CMakeLists.txt || die
sed -i '/-fsanitize=/d' test/CMakeLists.txt || die
+
+ # Fix build with CLANG and LLD.
+ # https://bugs.gentoo.org/831338
+ append-flags -fPIC
}