summaryrefslogtreecommitdiff
path: root/net-libs/telepathy-qt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /net-libs/telepathy-qt
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'net-libs/telepathy-qt')
-rw-r--r--net-libs/telepathy-qt/Manifest3
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild10
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-9999.ebuild82
3 files changed, 89 insertions, 6 deletions
diff --git a/net-libs/telepathy-qt/Manifest b/net-libs/telepathy-qt/Manifest
index 8fc974f9c57f..dcb3bbb8f601 100644
--- a/net-libs/telepathy-qt/Manifest
+++ b/net-libs/telepathy-qt/Manifest
@@ -1,3 +1,4 @@
DIST telepathy-qt-0.9.8.tar.gz 6448686 BLAKE2B 7554b812c35a09aabc0ff92fea43f633b5c2f87784c8e7b387545b31c1c92eb02f9e416930c635202fe0205c4e26c1fd63c3b4a668cf0ceeb602d8a777891cd9 SHA512 fad662c02417c8e4e239d438ea3549226e589442aea8418c8922a6b78ff88422a36c1cc0d2e3591240fac115390a7fbdb1b4deea98187051cc811175b60b9e8b
-EBUILD telepathy-qt-0.9.8.ebuild 1484 BLAKE2B 0e09cc5d671686c52243669f02fb644fda4b76e6f384b7b2db514e5c0196deb4fdda06c919c095f024b3c2b9150d806573a28af07c5692487b0f414cf7d38dba SHA512 25a87c7168cbde43a73efd18c1a2fdd2efd8e7602fe1ca6a8db759e18a733e2d78328125427ca2c77f5d43999dd9b38646c38f5a40654f965d21711548c9b4ce
+EBUILD telepathy-qt-0.9.8.ebuild 1464 BLAKE2B a6ceb45fd0549a6c27be49421d7b1e21d09b92022f5141a5cc2d4b139bafff8a29b38b3d8264bccdecee0f01322141ac90caef22c376f91e9e6c6c6f741d5bcb SHA512 4e9feaae5a2827ff27cf4604ad98ba4f273973c7e0da9cb2c697ecf49294cefce305d56aa95c6f960021da9ffd85bdbaf677abfc661403e54b28241cfda2d996
+EBUILD telepathy-qt-9999.ebuild 1607 BLAKE2B 45c28da9a88a5289302901f8fbca6ac04b370c6c09e386bafa0d0a732ad148fa330f4296302c7c2ed8cd56ba73f121e54f5ae5e848a4389d2215839b04ce696b SHA512 c46bf6f4586c45c688c6ebeaba735a5b1e69df54264f08daba5ab2f9c1b92948a841bb86d47899eaa5549c9b892b7748136c775e2a478e456b234c0e5de5dad0
MISC metadata.xml 691 BLAKE2B 6539a5f9248a6f49fe13ba408b6c04a54f212c684e0dae59cbc6b510e4ddb0440dd74f9afa0540308f1c1239fcf044531d8a088b7cb98da39896a54e6c82b848 SHA512 9fd71fef229868f3b0495ad64e5845420258b92f4773da7a74e45d3c5f0d23ae738cb219bb5050c68223950652f32ed6e31ccd580f732ebc26700cda64b44891
diff --git a/net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild b/net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild
index 1f505982cf39..12ca100f7091 100644
--- a/net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild
+++ b/net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{5,6,7} )
-inherit python-any-r1 cmake-utils virtualx
+PYTHON_COMPAT=( python3_{6,7} )
+inherit python-any-r1 cmake virtualx
DESCRIPTION="Qt bindings for the Telepathy D-Bus protocol"
HOMEPAGE="https://telepathy.freedesktop.org/"
@@ -61,7 +61,7 @@ src_configure() {
-DENABLE_TESTS=$(usex test)
-DENABLE_EXAMPLES=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
@@ -70,6 +70,6 @@ src_test() {
-E "(BaseConnectionManager|BaseProtocol)"
)
pushd "${BUILD_DIR}" > /dev/null || die
- virtx cmake-utils_src_test
+ virtx cmake_src_test
popd > /dev/null || die
}
diff --git a/net-libs/telepathy-qt/telepathy-qt-9999.ebuild b/net-libs/telepathy-qt/telepathy-qt-9999.ebuild
new file mode 100644
index 000000000000..84ab23609aac
--- /dev/null
+++ b/net-libs/telepathy-qt/telepathy-qt-9999.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI=( "https://gitlab.freedesktop.org/telepathy/${PN}" )
+ inherit git-r3
+else
+ SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+inherit python-any-r1 cmake virtualx
+
+DESCRIPTION="Qt bindings for the Telepathy D-Bus protocol"
+HOMEPAGE="https://telepathy.freedesktop.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="debug farstream test"
+
+REQUIRED_USE="test? ( farstream )"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig
+ test? (
+ dev-libs/glib:2
+ $(python_gen_any_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtxml:5
+ farstream? (
+ >=net-libs/telepathy-farstream-0.2.2
+ >=net-libs/telepathy-glib-0.18.0
+ )
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/dbus-glib
+ dev-qt/qttest:5
+ )
+"
+
+python_check_deps() {
+ use test || return 0
+ has_version "dev-python/dbus-python[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DEBUG_OUTPUT=$(usex debug)
+ -DENABLE_FARSTREAM=$(usex farstream)
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_EXAMPLES=OFF
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ # some tests require D-Bus
+ local myctestargs=(
+ -E "(BaseConnectionManager|BaseProtocol)"
+ )
+ pushd "${BUILD_DIR}" > /dev/null || die
+ virtx cmake_src_test
+ popd > /dev/null || die
+}