summaryrefslogtreecommitdiff
path: root/net-libs/telepathy-farstream/telepathy-farstream-0.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/telepathy-farstream/telepathy-farstream-0.6.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/telepathy-farstream/telepathy-farstream-0.6.2.ebuild')
-rw-r--r--net-libs/telepathy-farstream/telepathy-farstream-0.6.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-libs/telepathy-farstream/telepathy-farstream-0.6.2.ebuild b/net-libs/telepathy-farstream/telepathy-farstream-0.6.2.ebuild
new file mode 100644
index 000000000000..d04f9dc1e79f
--- /dev/null
+++ b/net-libs/telepathy-farstream/telepathy-farstream-0.6.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Telepathy client library that uses Farstream to handle Call channels"
+HOMEPAGE="https://telepathy.freedesktop.org/"
+SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/3"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="examples +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=sys-apps/dbus-0.60
+ >=dev-libs/dbus-glib-0.60
+ media-libs/gstreamer:1.0[introspection?]
+ >=net-libs/telepathy-glib-0.21[introspection?]
+ net-libs/farstream:0.2=[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.30 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.17
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --disable-Werror \
+ $(use_enable introspection)
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ insinto /usr/share/doc/${PF}/examples/python
+ doins examples/python/*.py
+ fi
+}