summaryrefslogtreecommitdiff
path: root/net-libs/stem/stem-1.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /net-libs/stem/stem-1.7.1.ebuild
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'net-libs/stem/stem-1.7.1.ebuild')
-rw-r--r--net-libs/stem/stem-1.7.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-libs/stem/stem-1.7.1.ebuild b/net-libs/stem/stem-1.7.1.ebuild
new file mode 100644
index 000000000000..9a38c64d97dd
--- /dev/null
+++ b/net-libs/stem/stem-1.7.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6,3_7})
+
+inherit vcs-snapshot distutils-r1
+
+DESCRIPTION="Stem is a Python controller library for Tor"
+HOMEPAGE="https://stem.torproject.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}]
+ net-vpn/tor )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="net-vpn/tor"
+
+DOCS=( docs/{_static,_templates,api,tutorials,{change_log,api,contents,download,faq,index,tutorials}.rst} )
+
+python_prepare_all() {
+ # Disable failing test
+ sed -i -e "/test_expand_path/a \
+ \ \ \ \ return" test/integ/util/system.py || die
+ sed -i -e "/test_parsing_with_example/a \
+ \ \ \ \ return" test/unit/manual.py || die
+ sed -i -e "/test_parsing_with_unknown_options/a \
+ \ \ \ \ return" test/unit/manual.py || die
+ sed -i -e "/test_saving_manual/a \
+ \ \ \ \ return" test/unit/manual.py || die
+ sed -i -e "/test_sdist_matches_git/a \
+ \ \ \ \ return" test/integ/installation.py || die
+ sed -i -e "/test_connections_by_ss/a \
+ \ \ \ \ return" test/integ/util/connection.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${PYTHON} run_tests.py --all --target RUN_ALL || die
+}