summaryrefslogtreecommitdiff
path: root/net-libs/shairplay/shairplay-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /net-libs/shairplay/shairplay-9999.ebuild
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'net-libs/shairplay/shairplay-9999.ebuild')
-rw-r--r--net-libs/shairplay/shairplay-9999.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/net-libs/shairplay/shairplay-9999.ebuild b/net-libs/shairplay/shairplay-9999.ebuild
index 76a24ddd83bc..f4af8a0449c9 100644
--- a/net-libs/shairplay/shairplay-9999.ebuild
+++ b/net-libs/shairplay/shairplay-9999.ebuild
@@ -1,25 +1,27 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools vcs-snapshot
+inherit autotools
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/juhovh/${PN}.git"
else
- EGIT_COMMIT="498bc5bcdd305e04721f94a04b9f26a7da72673f"
+ EGIT_COMMIT="096b61ad14c90169f438e690d096e3fcf87e504e"
SRC_URI="https://github.com/juhovh/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
KEYWORDS="~amd64 ~x86"
fi
DESCRIPTION="Apple airplay and raop protocol server"
HOMEPAGE="https://github.com/juhovh/shairplay"
-LICENSE="BSD LGPL-2.1 MIT"
+LICENSE="BSD LGPL-2.1 MIT
+ playfair? ( GPL-3+ )"
SLOT="0"
-IUSE="alac static-libs tools"
+IUSE="alac +playfair static-libs tools"
DEPEND="
tools? ( media-libs/libao )
@@ -43,6 +45,7 @@ src_prepare() {
src_configure() {
econf \
+ $(use_with playfair) \
$(use_enable static-libs static)
}