summaryrefslogtreecommitdiff
path: root/net-libs/shairplay/shairplay-0_pre20180824-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /net-libs/shairplay/shairplay-0_pre20180824-r1.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'net-libs/shairplay/shairplay-0_pre20180824-r1.ebuild')
-rw-r--r--net-libs/shairplay/shairplay-0_pre20180824-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-libs/shairplay/shairplay-0_pre20180824-r1.ebuild b/net-libs/shairplay/shairplay-0_pre20180824-r1.ebuild
new file mode 100644
index 000000000000..e8573a8c12b6
--- /dev/null
+++ b/net-libs/shairplay/shairplay-0_pre20180824-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/juhovh/${PN}.git"
+else
+ EGIT_COMMIT="096b61ad14c90169f438e690d096e3fcf87e504e"
+ SRC_URI="https://github.com/juhovh/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Apple airplay and raop protocol server"
+HOMEPAGE="https://github.com/juhovh/shairplay"
+LICENSE="BSD LGPL-2.1 MIT
+ playfair? ( GPL-3+ )"
+
+SLOT="0"
+IUSE="+playfair static-libs"
+
+DEPEND="
+ net-dns/avahi[mdnsresponder-compat]
+ media-libs/libao
+"
+
+RDEPEND="
+ ${DEPEND}
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with playfair) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}