summaryrefslogtreecommitdiff
path: root/net-libs/shairplay/shairplay-0_pre20170118.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/shairplay/shairplay-0_pre20170118.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/shairplay/shairplay-0_pre20170118.ebuild')
-rw-r--r--net-libs/shairplay/shairplay-0_pre20170118.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-libs/shairplay/shairplay-0_pre20170118.ebuild b/net-libs/shairplay/shairplay-0_pre20170118.ebuild
new file mode 100644
index 000000000000..0df35df053a7
--- /dev/null
+++ b/net-libs/shairplay/shairplay-0_pre20170118.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools vcs-snapshot
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/juhovh/${PN}.git"
+else
+ EGIT_COMMIT="498bc5bcdd305e04721f94a04b9f26a7da72673f"
+ SRC_URI="https://github.com/juhovh/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+fi
+
+DESCRIPTION="Apple airplay and raop protocol server"
+HOMEPAGE="https://github.com/juhovh/shairplay"
+LICENSE="BSD LGPL-2.1 MIT"
+
+SLOT="0"
+IUSE="alac static-libs tools"
+
+DEPEND="
+ tools? ( media-libs/libao )
+"
+
+RDEPEND="
+ alac? (
+ media-sound/alac_decoder
+ net-libs/shairplay[tools]
+ )
+ tools? (
+ dev-libs/openssl:0=
+ net-dns/avahi[mdnsresponder-compat]
+ )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}