summaryrefslogtreecommitdiff
path: root/net-libs/rpc2/rpc2-2.14-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /net-libs/rpc2/rpc2-2.14-r1.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'net-libs/rpc2/rpc2-2.14-r1.ebuild')
-rw-r--r--net-libs/rpc2/rpc2-2.14-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-libs/rpc2/rpc2-2.14-r1.ebuild b/net-libs/rpc2/rpc2-2.14-r1.ebuild
new file mode 100644
index 000000000000..6e2f4af36aa0
--- /dev/null
+++ b/net-libs/rpc2/rpc2-2.14-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Remote procedure call package for IP/UDP (used by Coda)"
+HOMEPAGE="http://www.coda.cs.cmu.edu/"
+SRC_URI="http://www.coda.cs.cmu.edu/pub/rpc2/src/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc x86"
+
+RDEPEND=">=sys-libs/lwp-2.5"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-respect-flags.patch
+ "${FILESDIR}"/${P}-include.patch
+)
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}