summaryrefslogtreecommitdiff
path: root/net-libs/quiche/quiche-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /net-libs/quiche/quiche-9999.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'net-libs/quiche/quiche-9999.ebuild')
-rw-r--r--net-libs/quiche/quiche-9999.ebuild71
1 files changed, 38 insertions, 33 deletions
diff --git a/net-libs/quiche/quiche-9999.ebuild b/net-libs/quiche/quiche-9999.ebuild
index 7bd57abb4a15..55a9755ce101 100644
--- a/net-libs/quiche/quiche-9999.ebuild
+++ b/net-libs/quiche/quiche-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,18 +8,20 @@ anyhow-1.0.26
aho-corasick-0.7.6
arrayvec-0.4.11
atty-0.2.14
-autocfg-1.0.0
+autocfg-1.0.1
backtrace-0.3.37
backtrace-sys-0.1.31
bitflags-1.2.1
+boring-sys-1.0.2
bstr-0.2.12
-bumpalo-3.4.0
+bumpalo-3.6.0
byteorder-1.3.4
cast-0.2.3
-cc-1.0.61
+cc-1.0.66
cfg-if-0.1.10
+cfg-if-1.0.0
clap-2.33.0
-cmake-0.1.44
+cmake-0.1.45
criterion-0.3.1
criterion-plot-0.4.1
crossbeam-deque-0.7.3
@@ -35,74 +37,77 @@ darling_macro-0.10.2
fnv-1.0.7
fuchsia-zircon-0.3.3
fuchsia-zircon-sys-0.3.3
+hashbrown-0.9.1
hermit-abi-0.1.8
ident_case-1.0.1
idna-0.1.5
iovec-0.1.4
itertools-0.8.2
-itoa-0.4.6
-js-sys-0.3.45
+itoa-0.4.7
+js-sys-0.3.47
kernel32-sys-0.2.2
lazy_static-1.4.0
-libc-0.2.80
+libc-0.2.84
libm-0.2.1
-log-0.4.11
+log-0.4.14
matches-0.1.8
maybe-uninit-2.0.0
memchr-2.3.3
memoffset-0.5.3
-mio-0.6.22
-miow-0.2.1
-net2-0.2.35
+mio-0.6.23
+miow-0.2.2
+net2-0.2.37
num-traits-0.2.11
num_cpus-1.12.0
-once_cell-1.4.1
+indexmap-1.6.1
+once_cell-1.5.2
oorandom-11.1.0
percent-encoding-1.0.1
plotters-0.2.12
proc-macro2-1.0.24
-qlog-0.3.0
-quote-1.0.7
+qlog-0.4.0
+quote-1.0.8
rayon-1.3.0
rayon-core-1.7.0
regex-1.3.5
regex-automata-0.1.9
regex-syntax-0.6.17
-ring-0.16.15
+ring-0.16.19
rustc_version-0.2.3
ryu-1.0.5
same-file-1.0.6
scopeguard-1.1.0
semver-0.9.0
semver-parser-0.7.0
-serde-1.0.117
-serde_derive-1.0.117
-serde_json-1.0.59
-serde_with-1.5.1
-serde_with_macros-1.2.2
+serde-1.0.123
+serde_derive-1.0.123
+serde_json-1.0.61
+serde_with-1.6.2
+serde_with_macros-1.3.0
slab-0.4.2
smallvec-1.4.0
spin-0.5.2
strsim-0.9.3
-syn-1.0.48
+syn-1.0.60
textwrap-0.11.0
tinytemplate-1.0.3
-tinyvec-0.3.4
+tinyvec-1.1.1
+tinyvec_macros-0.1.0
unicode-bidi-0.3.4
-unicode-normalization-0.1.13
+unicode-normalization-0.1.16
unicode-width-0.1.7
unicode-xid-0.1.0
unicode-xid-0.2.1
untrusted-0.7.1
url-1.7.2
walkdir-2.3.1
-wasm-bindgen-0.2.68
-wasm-bindgen-backend-0.2.68
-wasm-bindgen-macro-0.2.68
-wasm-bindgen-macro-support-0.2.68
-wasm-bindgen-shared-0.2.68
-wasm-bindgen-webidl-0.2.68
-web-sys-0.3.45
+wasm-bindgen-0.2.70
+wasm-bindgen-backend-0.2.70
+wasm-bindgen-macro-0.2.70
+wasm-bindgen-macro-support-0.2.70
+wasm-bindgen-shared-0.2.70
+wasm-bindgen-webidl-0.2.70
+web-sys-0.3.47
winapi-0.2.8
winapi-0.3.9
winapi-build-0.1.1
@@ -141,7 +146,7 @@ IUSE=""
DOCS=( CODEOWNERS COPYING README.md )
BDEPEND="
- >=virtual/rust-1.39.0[${MULTILIB_USEDEP}]
+ >=virtual/rust-1.47.0[${MULTILIB_USEDEP}]
dev-util/cmake
"
DEPEND=""
@@ -176,7 +181,7 @@ multilib_src_configure() {
multilib_src_compile() {
BUILD_DIR="${BUILD_DIR}/deps/boringssl/build" cmake-utils_src_compile bssl
- QUICHE_BSSL_PATH="${BUILD_DIR}/deps/boringssl" cargo_src_compile --features pkg-config-meta --target="$(rust_abi)"
+ QUICHE_BSSL_PATH="${BUILD_DIR}/deps/boringssl" cargo_src_compile --features "ffi pkg-config-meta" --target="$(rust_abi)"
}
multilib_src_test() {